axis-c-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Srinivas Umareddy (JIRA)" <>
Subject [jira] Commented: (AXISCPP-1072) AxisSoapException: Soap message content is not valid. Unexpected or extraneous element (ProductInformation) encountered.
Date Tue, 27 Jul 2010 01:16:22 GMT


Srinivas Umareddy commented on AXISCPP-1072:

have debugged axis_client code with my client stub code and my webservice return 
getCmplxObject() call. Looks like latest code is not handling the array of structures.

For wsdl file, WSDL2WS generated the below entry code.

// ======================================================================

// Invoke web service, send/receive operation. Handle output parameters, if any.

// ======================================================================

if (AXIS_SUCCESS == m_pCall->sendAndReceive())


if(AXIS_SUCCESS == m_pCall->validateMessage("ProductInfoResponse", "",


pReturn = (ProductInfoArray*)m_pCall->getCmplxObject((void*) Axis_DeSerialize_ProductInfoArray,
(void*) Axis_Create_ProductInfoArray, (void*) Axis_Delete_ProductInfoArray,"ProductInfoArray",



getCmplxObject() call returning from below loop beacuse  pName ( value =ProductInfoArray )
and m_pNode->m_pchNameOrValue( value ="ProductInfoResponse") not matching. why this mismatch
if (RPC_ENCODED != m_nStyle) // TODO - why do we selectively do this check and not for all?

if (0 != strcmp (pName, m_pNode->m_pchNameOrValue))



* TODO: Need to verify what WS-I 1.0 says

* about the mandatory of all the elements in the response in case of

* null value or none filled value. Some Web services servers work

* like this. This apply for all the rest of the deserializer.



return NULL; 

why my wsdl is going this loop?. I have tested this with 1.6b banaires and it worked fine
but it was failing larger xml data. Looks like lot of change happed to svn code compare to

We are using so far axis cpp 1.6b binaries which are compiled on VC++ 6 and they worked great
except larger xml. Please let me know your suggesation on this. Do you guys want us to use
old binaries?.  Or moving Axis 2 will fix  larger xml problem?

Caterpilar is using the axis c++ for many project for integrating teamcenter with legacy system.

I spent two weeks on compilation with new parser and svn code but didn't work. I tried couple
of time compile the axis code vc+ 2003 but failed now i have build all the binaries on VC++
2005 both release and debug version but not having much exposer to webservies to fix this
issue. Please help us on this critical issue.

> AxisSoapException: Soap message content is not valid. Unexpected or extraneous element
(ProductInformation) encountered.
> ------------------------------------------------------------------------------------------------------------------------
>                 Key: AXISCPP-1072
>                 URL:
>             Project: Axis-C++
>          Issue Type: Bug
>          Components: Client - Deserialization
>    Affects Versions: current (nightly)
>         Environment: Axis Client : latest code from SVN 
> XMLParser: xerces-c-2.7.0
> WSDL2WS: Build with latest code using Axis Java 1.4
> Compiler: VC++ 2005(Vc8)
>            Reporter: Srinivas Umareddy
>             Fix For: current (nightly)
>         Attachments: axisclient.log, NPIDataServices.wsdl
> I have rebuild Axis c++ client code with latest code using xerces-c-2.7.0. I have generate
the my cilent code with latest wsdl2ws tool. I see checkForExtraneousElements() introduced
with latest wsdl2ws. 
> I am getting below error message when i execute the new code. Looks like some thing broken
or i am missing some thing. 
> Here is my soap responce.
> <soapenv:Envelope xmlns:soapenv="" xmlns:xsd=""
>  <soapenv:Body>
>   <ProductInfoResponse xmlns="">
>    <ProductInfoResponse xmlns="">
>     <SerialNumber>B1L</SerialNumber>
>     <ProductGroup>ARTICULATED TRUCKS</ProductGroup>
>     <GenericModel>725</GenericModel>
>     <PrimaryModel>725</PrimaryModel>
>     <SerialNumberBuilt>2250</SerialNumberBuilt>
>     <LastBuild>2010-04-30 00:00:00.0</LastBuild>
>     <Facility>PETERLEE (U2)</Facility>
>     <EngineeringModel>RM715</EngineeringModel>
>     <EngineeringVersion>-</EngineeringVersion>
>     <GeneralArrangement >2268615</GeneralArrangement >
>     <AssociatedModel>RM574</AssociatedModel>
>     <ProductType>AD</ProductType>
>     <CaptiveEngineModel>C11</CaptiveEngineModel>
>     <EngineFacilityCode>40</EngineFacilityCode>
>     <EngineFamily>ZE</EngineFamily>
>     <OldNewAssociatedModel>O</OldNewAssociatedModel>
>    </ProductInfoResponse>
>   </ProductInfoResponse>
>  </soapenv:Body>
> </soapenv:Envelope>
> Looks above soap not having any extraneous element. Why my client code is not working.

> please help on this issue. 

This message is automatically generated by JIRA.
You can reply to this email to add a comment to the issue online.

To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message