axis-c-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Srinivas Umareddy (JIRA)" <>
Subject [jira] Commented: (AXISCPP-1072) AxisSoapException: Soap message content is not valid. Unexpected or extraneous element (ProductInformation) encountered.
Date Tue, 27 Jul 2010 15:31:20 GMT


Srinivas Umareddy commented on AXISCPP-1072:

Looks like there is some bug in below if condition. All my webservice client are coming out
for below if condition beacuse client are passing return array name ( in my case ProductInfoArray)
for pName in the getCmplxObject() method and m_pNode->m_pchNameOrValue valuse top element
name ( in my case ProductInfoResponse).

if (RPC_ENCODED != m_nStyle) // TODO - why do we selectively do this check and not for all?

if (0 != strcmp (pName, m_pNode->m_pchNameOrValue)) 



* TODO: Need to verify what WS-I 1.0 says 

* about the mandatory of all the elements in the response in case of 

* null value or none filled value. Some Web services servers work 

* like this. This apply for all the rest of the deserializer. 



return NULL; 


My webservice started working when i comment the return form above loop or if  pass the ProductInfoResponse
name for pName in the getCmplxObject() method from client code.

Let me know which is wrong ? client stub or above code . I didn't understand why we are doing
above check it always come out. 

> AxisSoapException: Soap message content is not valid. Unexpected or extraneous element
(ProductInformation) encountered.
> ------------------------------------------------------------------------------------------------------------------------
>                 Key: AXISCPP-1072
>                 URL:
>             Project: Axis-C++
>          Issue Type: Bug
>          Components: Client - Deserialization
>    Affects Versions: current (nightly)
>         Environment: Axis Client : latest code from SVN 
> XMLParser: xerces-c-2.7.0
> WSDL2WS: Build with latest code using Axis Java 1.4
> Compiler: VC++ 2005(Vc8)
>            Reporter: Srinivas Umareddy
>             Fix For: current (nightly)
>         Attachments: axisclient.log, NPIDataServices.wsdl
> I have rebuild Axis c++ client code with latest code using xerces-c-2.7.0. I have generate
the my cilent code with latest wsdl2ws tool. I see checkForExtraneousElements() introduced
with latest wsdl2ws. 
> I am getting below error message when i execute the new code. Looks like some thing broken
or i am missing some thing. 
> Here is my soap responce.
> <soapenv:Envelope xmlns:soapenv="" xmlns:xsd=""
>  <soapenv:Body>
>   <ProductInfoResponse xmlns="">
>    <ProductInfoResponse xmlns="">
>     <SerialNumber>B1L</SerialNumber>
>     <ProductGroup>ARTICULATED TRUCKS</ProductGroup>
>     <GenericModel>725</GenericModel>
>     <PrimaryModel>725</PrimaryModel>
>     <SerialNumberBuilt>2250</SerialNumberBuilt>
>     <LastBuild>2010-04-30 00:00:00.0</LastBuild>
>     <Facility>PETERLEE (U2)</Facility>
>     <EngineeringModel>RM715</EngineeringModel>
>     <EngineeringVersion>-</EngineeringVersion>
>     <GeneralArrangement >2268615</GeneralArrangement >
>     <AssociatedModel>RM574</AssociatedModel>
>     <ProductType>AD</ProductType>
>     <CaptiveEngineModel>C11</CaptiveEngineModel>
>     <EngineFacilityCode>40</EngineFacilityCode>
>     <EngineFamily>ZE</EngineFamily>
>     <OldNewAssociatedModel>O</OldNewAssociatedModel>
>    </ProductInfoResponse>
>   </ProductInfoResponse>
>  </soapenv:Body>
> </soapenv:Envelope>
> Looks above soap not having any extraneous element. Why my client code is not working.

> please help on this issue. 

This message is automatically generated by JIRA.
You can reply to this email to add a comment to the issue online.

To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message