axis-c-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "S.Uthaiyashankar (JIRA)" <j...@apache.org>
Subject [jira] Resolved: (AXIS2C-1407) Loading an XML file always sets the env status to AXIS2FAILURE
Date Tue, 23 Mar 2010 10:13:28 GMT

     [ https://issues.apache.org/jira/browse/AXIS2C-1407?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

S.Uthaiyashankar resolved AXIS2C-1407.
--------------------------------------

    Resolution: Fixed

Fixed in revision 926515

> Loading an XML file always sets the env status to AXIS2FAILURE
> --------------------------------------------------------------
>
>                 Key: AXIS2C-1407
>                 URL: https://issues.apache.org/jira/browse/AXIS2C-1407
>             Project: Axis2-C
>          Issue Type: Bug
>          Components: xml/om
>            Reporter: Francois Mireaux
>            Assignee: S.Uthaiyashankar
>             Fix For: 1.7.0
>
>
> In om_stax_builder.c, the loop condition in axiom_stax_builder_next is not correct, leading
to exit of the function by the if om_builder->done which set the env status to AXIS2FAILURE.
Instead of  'while(!node)', the condition should be 'while(!node && !axiom_node_is_complete(om_builder->root_node,
env))' to exit in error only in the root XML element is not closed. Problem is concealed notably
because of the AXIS2_PARAM_CHECK macro which, usualy, resets the status to OK. But some days
ago, the macro was temporaly modified to not reset the status (which seems the good way) and
I track down the resulting error(s).

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


---------------------------------------------------------------------
To unsubscribe, e-mail: c-dev-unsubscribe@axis.apache.org
For additional commands, e-mail: c-dev-help@axis.apache.org


Mime
View raw message