axis-c-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "S.Uthaiyashankar (JIRA)" <>
Subject [jira] Created: (AXIS2C-1403) Code generation having problem in Windows
Date Fri, 16 Oct 2009 03:34:31 GMT
Code generation having problem in Windows

                 Key: AXIS2C-1403
             Project: Axis2-C
          Issue Type: Bug
          Components: wsdl2c tool
    Affects Versions: 1.6.0
         Environment: Windows
            Reporter: S.Uthaiyashankar
             Fix For: Next Version

Error reported in mailing list by Pete Maclean:

I am attempting to use Axis2/c 1.6.0 to generate C client stubs in Windows with the "-d adb"
option for use with the Microsoft C compiler and am facing three problems.

First I had trouble actually generating the stubs using the WSDL2C.bat file supplied in the
package.  I got past this obstacle by changing the line that read:

java -classpath %AXIS2_CLASSPATH% org.apache.axis2.wsdl.WSDL2C %*


java -classpath "%AXIS2_CLASSPATH%" org.apache.axis2.wsdl.WSDL2C %*

Since I can see no downside to it, may I suggest that this change be made to the distribution
package.  It could save a bit of puzzlement and frustration.

The other problems cause the generated code to get compilation errors.  The second is that
declarations are generated that are not at the top of their blocks.  I see code like this:

                 axiom_node_t *text_node = NULL;
                 text_node = axiom_node_get_first_child(parent, env);
                 axiom_text_t *text_element = NULL;

This is fine in C++ but not in plain C.


This message is automatically generated by JIRA.
You can reply to this email to add a comment to the issue online.

View raw message