axis-c-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "David K. Taylor (JIRA)" <j...@apache.org>
Subject [jira] Updated: (AXIS2C-1244) Axis2/C HTTP transport sends SOAP calls twice when using BASIC auth
Date Thu, 14 May 2009 14:14:46 GMT

     [ https://issues.apache.org/jira/browse/AXIS2C-1244?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

David K. Taylor updated AXIS2C-1244:
------------------------------------

    Attachment: axis2c-1244.txt

Attached is a patch, axis2c-1244.txt, that fixes this bug.  It is a simple change to add a
missing "else" keyword to http_sender.c to keep the BASIC authentication message from being
sent twice.

> Axis2/C HTTP transport sends SOAP calls twice when using BASIC auth
> -------------------------------------------------------------------
>
>                 Key: AXIS2C-1244
>                 URL: https://issues.apache.org/jira/browse/AXIS2C-1244
>             Project: Axis2-C
>          Issue Type: Bug
>          Components: transport/http
>    Affects Versions: 1.4.0
>         Environment: Linux i686
>            Reporter: Chris Rose
>            Assignee: S.Uthaiyashankar
>            Priority: Blocker
>             Fix For: 1.6.0
>
>         Attachments: axis2c-1244.txt
>
>
> When I send a SOAP request using the built-in HTTP transport using HTTP-Basic authentication,
the request ends up being sent two times.  I've verified this with tcpmon, and I've stepped
into the code to see that it's happening.
> The code that's doing this is in the 1.4.0 unix release tarball, in src/core/transport/http/sender/http_sender.c
at line 973 (where force_http_auth is true due to an earlier call to axis2_options_set_http_auth_info
with auth type = Basic) and then later in the false branch of the check on line 995, which
starts on line 1054 of http_sender.c.
> The status code values from the initial calls don't seem to be checked, because they've
plainly succeeded at this point.
> This is a dead-in-the-water blocker for us, with a release to a client coming up in four
days.  I don't have the time to upgrade to 1.5.0 on all of our tested platforms (because we're
shipping this on Solaris as well, and that requires some patches to Axis2/C that we've got
done for 1.4.0 and will be sending in one of these days).  I realize it's a bit presumptuous,
but could someone suggest a patch to this that would allow me to proceed?

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message