axis-c-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From PP <patelprad...@gmail.com>
Subject error during starting axis2_http_server on AIX
Date Thu, 12 Mar 2009 07:21:31 GMT
Hi

We are building axis2c on AIX and we are facing some build problems.
There were lot of compilation issues. I was able to solve them by following
the instructions from this Jira issue.
http:
//mail-archives.apache.org/mod_mbox/ws-axis-c-dev/200810.mbox/%3C1C5078180E92E9
4595BBC384F5F3FC3B0206A8B6@USCOBRMFA-SE-70.northamerica.cexp.com%3E<http://mail-archives.apache.org/mod_mbox/ws-axis-c-dev/200810.mbox/%3C1C5078180E92E94595BBC384F5F3FC3B0206A8B6@USCOBRMFA-SE-70.northamerica.cexp.com%3E>

Then i got the shared libs as .a files on AIX. Now when i start the server i
get this error message. The server tries to load the library and the lib is
available in the location but the problem is in the lib format according to
the error message.

The error is:
[Mon Mar  2 13:26:20 2009] [error] class_loader.c(162) Loading shared
library ..//lib/libaxis2_http_sender.a  Failed. DLERROR IS        0509-022
Cannot load module ../lib/libaxis2_http_sender.a.
        0509-103   The module has an invalid magic number.

can someone please help what could be the error? Or can you plase let me
know what are options that needs to be passed while using gcc on AIX to
build axis2c?


My env is:
AIX-rpm-6.1.0.0-1
axis2c-src-1.5.0

gcc-cpp-4.2.3-1
gcc-4.2.3-1
libgcc-4.2.3-1


Thanks & Regards
Pradeep Patel

Mime
View raw message