axis-c-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hatim Daginawala" <Hatim.Daginaw...@argodata.com>
Subject axiom_node_serialize does not serialize namespaces properly
Date Thu, 31 Jul 2008 17:26:07 GMT
Hi All,

 

Here is the sample XML I am working with:

<s:Envelope xmlns:s="http://schemas.xmlsoap.org/soap/envelope/">

    <s:Header>

        <h:guid s:mustUnderstand="1"
xmlns:h="http://localhost/namespce/header/">00000000-0000-0000-0000-0000
00000001</h:guid>

    </s:Header>

    <s:Body>

        <EchoParm xmlns="http://localhost/namespce/body/">

            <str>Response: Hello EchoEx</str>

        </EchoParm>

    </s:Body>

</s:Envelope>

 

When I retrieve guid node and serialize it with libxml2 the XML I get
is:

<h:guid s:mustUnderstand="1"
xmlns:h="http://localhost/namespce/header/">00000000-0000-0000-0000-0000
00000001</h:guid>

 

When I retrieve guid node and serialize it with guththila the XML I get
is:

<h:guid xmlns:h="http://localhost/namespce/header/"
xmlns:s="http://schemas.xmlsoap.org/soap/envelope/"
s:mustUnderstand="1">00000000-0000-0000-0000-000000000001</h:guid>

 

I have a test program to show this behavior, if anyone would like to try
it out.

 

Is this a known bug or should I raise a JIRA for this?

 

I am stuck with using libxml2 since guththila seems to show some major
memory leaks in my application. Any insight to fix libxml wrapper so
that it outputs valid XML will be greatly appreciated.

 

Thank you!



---------------------------------------------------
Confidentiality Notice:  This electronic mail transmission is confidential, 
may be privileged and should be read or retained only by the intended
recipient.  If you have received this transmission in error, please
immediately notify the sender and delete it from your system.

Mime
View raw message