axis-c-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Manjula Peiris <manj...@wso2.com>
Subject Re: About Bug report for axis2/c
Date Sat, 31 May 2008 17:41:55 GMT
Denis,

In the server side to use SSL you need to use Axis2/C with Apache2.
Seems to me you are using simple_axis2_http_server for SSL support.
simple_axis2_http_server does not support SSL.

Thanks,
-Manjula.


On Sat, 2008-05-31 at 18:22 -0700, denis zhytnik wrote:
> Hello.
> I have a problem with connecting to axis2/c server over SSL. I use 1.4 
> version of Axis2/c and 0_9_8g version of OpenSSL. I have built Axis2/c 
> with ENABLE_SSL=1, and the server seems to be built correctly. I run the 
> server with parametr -p 443. But when I try to run the following command:
> *>>>openssl s_client -connect localhost:443*
> I can not receive any answer, though I see message
> *>>>connected(00000780).
> *and nearly two minutes later I get message "ssl handshake failure"
> 
> Here is the strings from the server's log file:
> /[Fri May 30 19:10:13 2008] [error] 
> ..\..\src\core\transport\http\common\http_request_line.c(112) Invalid 
> status line or invalid request line
> [Fri May 30 19:10:13 2008] [error] 
> ..\..\src\core\transport\http\common\simple_http_svr_conn.c(206) Invalid 
> status line or invalid request line
> [Fri May 30 19:10:13 2008] [warning] 
> ..\..\src\core\transport\http\receiver\http_svr_thread.c(285) Error 
> occured in processing request
> /Can anybody help me in solving my problem?
> Thanks.
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: axis-c-dev-unsubscribe@ws.apache.org
> For additional commands, e-mail: axis-c-dev-help@ws.apache.org
> 


---------------------------------------------------------------------
To unsubscribe, e-mail: axis-c-dev-unsubscribe@ws.apache.org
For additional commands, e-mail: axis-c-dev-help@ws.apache.org


Mime
View raw message