axis-c-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Senaka Fernando" <>
Subject Re: MSVCR80
Date Sat, 05 Apr 2008 10:15:13 GMT
Hi Devs,

has anyone run Axis2/C win32 binary lately?

If so, have you run into this issue.


>         Hi Supun, Senaka
>  Given the suggestions of Supun, I have tried the following without
> result:
>  - removed the directory and  unzipped the contents of
> again.
>  - removed the directory and tried a previous version
>  - placed one of the copies of MSVCR80.dll found on my machine in the
> windows/system32 directory (in this case a different error occurs)
>  - read the post on
>  Given the suggestions of Senaka:
>  - many problems with  MSVCR80.dll posted on the internet seem to have to
> do with manifest files indeed. Some replies describe how problems can be
> fixed , but I don't imagine that such specialized actions would be needed
> to get the examples shipped with axis2c running. Anyway, my clients would
> not be able to repeat these steps.
>  - Initially I was working with Microsoft Visual C++ 6.0 (1994-1998)
>  - Meanwhile I have installed express editions of Microsoft Visual C++ 9.0
> (2008)  and Microsoft Visual C++ 2005
>  - I have compiled a 1 line console application with Microsoft Visual C++
> 2005 which runs from the dos prompt
>  - I work on a machine with xp64 SP2 installed, the problem reproduces on
> a XP machine (although this machine had no Microsoft Visual 2005)
>  After the above steps, the MSVCR80.dll error still appears when starting
> "axis2_http_server.exe". If I try any of the exe files in the directory
> "samples", the same error occurs.
>  Kind regards,
>  Nanne
>  Senaka Fernando schreef:    Hi Supun, Nanne,  I can be that someone build
> without embedding the manifest files, and then removed the manifest files
> before packing. Or else it may be that you have an embedded or visible
> manifest that needs a different version of MSVCR80.dll. Nanne, btw, what
> is your VS version (don't you have VS at all?) and what is your win32
> version (WinXP/Vista version)?  We have not run into this issue with the
> Axis2/C 1.3.0 binary. But, in my case I had Windows XP SP2, and Visual
> Studio 2005.  Regards, Senaka            Hi Nanne,  This occurs all the
> time to me also. When this occurs I simply clean all the binaries and
> build them again and the error vanishes. So I couldn't find a specific
> reason for this error to occur. It seems that building the binaries is
> not an option for you. So I suggest delete all the Axis2/C binaries and
> start again.  Also this post might help.
> Regards, Supun.  On Fri, Apr 4, 2008 at 12:02 PM,
> wrote:                 Hello,   I am a newbe to axis2c. I would like to
> run the example "axis2_http_server.exe" as a first step.   I have
> downloaded the binary distribution and followed the steps on
>   In
> step 2.1.3 (Running the binaries) I have set and verified AXIS2C_HOME and
> the PATH variable and now try to run axis2_http_server.exe   Then an
> error message "This application failed to start because MSVR80.dll was
> not found" appears in a dialog box.   Simply copying this file to the
> library path does  not really help because then a different error
> appears.   I have repeated the procedure on a different PC with exactlty
> identical results.   I searched the mailing list, and found some hits on
> "MSVCR80" but was not able to resolve the problem.   Does anywone know
> what to do?   Regard,  Nanne
> ---------------------------------------------------------------------  To
> unsubscribe, e-mail:  For
> additional commands, e-mail:
>     ---------------------------------------------------------------------
> To unsubscribe, e-mail: For
> additional commands, e-mail:
> --------------------------------------------------------------------- To
> unsubscribe, e-mail: For additional
> commands, e-mail:
>      ---------------------------------------------------------------------
> To unsubscribe, e-mail: For
> additional commands, e-mail:

To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message