axis-c-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Senaka Fernando (JIRA)" <j...@apache.org>
Subject [jira] Commented: (AXIS2C-941) IIS Module: fails with large data element
Date Wed, 06 Feb 2008 07:01:10 GMT

    [ https://issues.apache.org/jira/browse/AXIS2C-941?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12566039#action_12566039
] 

Senaka Fernando commented on AXIS2C-941:
----------------------------------------

Hi Dave,

I see your point. Now the failure has something to do with mtom. That is what I basically
wanted to clarify. There is an issue with the mime parser, specifcally in the way it handles
attachments. AFAIK, there are two issues raised for this, when it comes to apache server +
mtom. I will hold on this issue until it has been fixed with apache, which will be done soon.
AFAIK Manjula is handling this. If the issue on IIS still lasts even after the fix has been
made for mod_axis2 (apache httpd module), meaning that it is an IIS specific issue, I will
have a look on that.


Regards,
Senaka

> IIS Module: fails with large data element
> -----------------------------------------
>
>                 Key: AXIS2C-941
>                 URL: https://issues.apache.org/jira/browse/AXIS2C-941
>             Project: Axis2-C
>          Issue Type: Bug
>          Components: transport/http
>    Affects Versions: Current (Nightly)
>         Environment: Windows XP, IIS 5.1
>            Reporter: Dave Meier
>         Attachments: aewebservicesaxis70.wsdl
>
>
> I have a web service that takes the following as input.  Here is the wsdl:
>   <complexType name="FileAttachmentContents">
>    <complexContent>
>     <extension base="ae:FileAttachment">
>      <sequence>
>      <element name="checksum" type="xsd:long" minOccurs="1" maxOccurs="1"/>
>      <element name="encodedContents" type="xsd:base64Binary" minOccurs="1" maxOccurs="1"
nillable="false"/>
>      </sequence>
>     </extension>
>    </complexContent>
>   </complexType>
> With the axis2_http_server.exe it works fine with a 163KB file, where the contents of
the file are written in base64 into the "encodedContents" element.  But when I run the IIS
module and run the same client test, I get back an error saying that the "encodedContents"
element is NULL.
> I tried a 1KB file with the IIS module and that worked great.  So there appears to be
something limiting the sending of a large element when using the IIS module.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


---------------------------------------------------------------------
To unsubscribe, e-mail: axis-c-dev-unsubscribe@ws.apache.org
For additional commands, e-mail: axis-c-dev-help@ws.apache.org


Mime
View raw message