axis-c-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Bill Mitchell" <bmitch...@austin.rr.com>
Subject RE: [jira] Commented: (AXIS2C-675) Detach node does not handle namespaces
Date Wed, 27 Feb 2008 14:59:21 GMT
Sanjaya, as Dinesh included the AXIS2C-675 fix into the head, should I include the new routine
to perform a copy of an axiom subtree into the axiomfix branch as it stands today?  Or would
it be better to recreate this branch starting at a later revision that already includes the
675 fix, to make the merge process later easier?  

Thanks,
Bill Mitchell 

-----Original Message-----
From: Dinesh Premalal (JIRA) [mailto:jira@apache.org] 
Sent: Friday, February 22, 2008 3:34 AM
To: wtmitchell3@acm.org
Subject: [jira] Commented: (AXIS2C-675) Detach node does not handle namespaces


    [ https://issues.apache.org/jira/browse/AXIS2C-675?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12571325#action_12571325
] 

Dinesh Premalal commented on AXIS2C-675:
----------------------------------------

Bill, I applied the patch and tested in the svn head, for me It didn't give any problem. Ill
commit it to the svn head.

> Detach node does not handle namespaces
> --------------------------------------
>
>                 Key: AXIS2C-675
>                 URL: https://issues.apache.org/jira/browse/AXIS2C-675
>             Project: Axis2-C
>          Issue Type: Bug
>          Components: xml/om
>            Reporter: Jamie Lyon
>            Assignee: Bill Mitchell
>         Attachments: diff.txt
>
>
> When detaching a node from a parent, if the current node or any of it's children have
any namespaces declared in it's parent or above, when the node is detached, and the parent
freed, any namespace references are lost.

-----Original Message-----
From: Sanjaya Ratnaweera [mailto:sanjaya@wso2.com] 
Sent: Thursday, February 21, 2008 10:37 AM
To: Apache AXIS C Developers List
Subject: Re: Issue in using 'detach' for cloning

Hi Bill,

    I have applied the updated patch to the branch. So I think we can have the branch ready
until we come to a decision.

thanks 

    ~sanjaya

Bill Mitchell wrote: 
Sanjaya, you raise a question that I was going to ask Dinesh.  In my mind, I see Jira 675
as a bug.  For some xml document trees, detach generates a structure that is later unusable
by the adb stubs that depend on it.  As such, it could still be a candidate for inclusion
in 1.3.  And I see our other two activities, an axiom_node_copy_tree and axiom_node_clone_tree
routines that solve some other, similar issues for the higher level apps as a new feature,
isolated and relatively safe, but still at this point warranting exclusion from any current
release activity as a new feature.  

But, it's not my decision; I think it's up to Dinesh.  

I did notice that you had built a branch, and I extracted a copy, although I think I grabbed
a copy by revision number.  I will be seeking today to take my axiom_node_copy_tree routine
and include it there.  

Thanks,
Bill

-----Original Message-----
From: Sanjaya Ratnaweera [mailto:sanjaya@wso2.com] 
Sent: Thursday, February 21, 2008 8:22 AM
To: Apache AXIS C Developers List
Subject: Re: Issue in using 'detach' for cloning

Hi bill,
  
I have created a branch for this. Here's the url.

https://svn.apache.org/repos/asf/webservices/axis2/branches/c/axiomfix/

    

I have applied your patch in jira issue 675 to this branch. It failed in 
a one file. (axiom/include/axiom_element.h). It had only api doc comment 
changes. The rest was ok.

Thanks

    ~sanjaya



---------------------------------------------------------------------
To unsubscribe, e-mail: axis-c-dev-unsubscribe@ws.apache.org
For additional commands, e-mail: axis-c-dev-help@ws.apache.org


Mime
View raw message