axis-c-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Dave Meier" <DMe...@SERENA.com>
Subject RE: [jira] Created: (AXIS2C-932) IIS module fails with service that has the name "services" in it
Date Mon, 28 Jan 2008 19:24:18 GMT
Hi Senaka,

Please advise how to create the diff for my patch.  I couldn't find
reference on how to do it and have not create a diff previously.

Thanks,

-Dave. 

-----Original Message-----
From: Senaka Fernando [mailto:senaka@wso2.com] 
Sent: Friday, January 25, 2008 11:09 PM
To: Apache AXIS C Developers List
Subject: Re: [jira] Created: (AXIS2C-932) IIS module fails with service
that has the name "services" in it

Hi Dave,

+1 for the fix. In anyway, this "services" prefix is also not a constant
in theory. Because it is configurable in apache, mod_axis2. I noticed
this last week. Better take a peek on that too. Please upload a diff of
your patch.

Regards,
Senaka

> IIS module fails with service that has the name "services" in it
> ----------------------------------------------------------------
>
>                  Key: AXIS2C-932
>                  URL: https://issues.apache.org/jira/browse/AXIS2C-932
>              Project: Axis2-C
>           Issue Type: Bug
>           Components: transport/http
>     Affects Versions: Current (Nightly)
>          Environment: Windows XP.
>             Reporter: Dave Meier
>             Priority: Critical
>
>
> When I use the IIS module and try to call my service it fails to find 
> the service.  The name of my service is "aewebservices70", so the URL 
> is "http://localhost:80/axis2/services/aewebservices70".  The service 
> is not found.
>
> I found that there is a loop in
> axutil_parse_request_url_for_svc_and_op(...) where it keeps looking 
> for "services" so it end up returning "70" as the service name.
> I modified the code to break out of the loop after the first 
> "services" is found and that fixed it.  I'm not sure if the loop is
there for a reason:
>
>     while (1)
>     {
>         tmp = strstr(tmp, axis2_request_url_prefix);
>         if (!tmp)
>         {
>             break;
>         }
>         else
>         {
>             service_str = tmp;
>             tmp += axutil_strlen(axis2_request_url_prefix);
>             break;    // I added this line to get it to
> work...............
>         }
>     }
>
>
> --
> This message is automatically generated by JIRA.
> -
> You can reply to this email to add a comment to the issue online.
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: axis-c-dev-unsubscribe@ws.apache.org
> For additional commands, e-mail: axis-c-dev-help@ws.apache.org
>
>


---------------------------------------------------------------------
To unsubscribe, e-mail: axis-c-dev-unsubscribe@ws.apache.org
For additional commands, e-mail: axis-c-dev-help@ws.apache.org


**********************************************************************
This email and any files transmitted with it are confidential and intended solely for the
use of the individual or entity to whom they are addressed. Any unauthorized review, use,
disclosure or distribution is prohibited. If you are not the intended recipient, please contact
the sender by reply e-mail and destroy all copies of the original message. 
**********************************************************************


---------------------------------------------------------------------
To unsubscribe, e-mail: axis-c-dev-unsubscribe@ws.apache.org
For additional commands, e-mail: axis-c-dev-help@ws.apache.org


Mime
View raw message