axis-c-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Senaka Fernando (JIRA)" <j...@apache.org>
Subject [jira] Commented: (AXIS2C-622) When a service is loaded with a module ref in service.xml, but without that module deployed then axis2 engine start fail
Date Mon, 22 Oct 2007 18:55:50 GMT

    [ https://issues.apache.org/jira/browse/AXIS2C-622?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel#action_12536789
] 

Senaka Fernando commented on AXIS2C-622:
----------------------------------------

I assume that you are using the axis2_http_server.

Now, if you go through the logs directory which is found in the parent directory of the bin
directory (the parent directory of the one in which you start the service), you will find
a fill named 'axis2_http_server.log'. Within this file, you will be able to locate something
similar to this '[error] http_server_main.c(192) Server creation failed: Error code: 34 ::
Repository listener initialization failed'. This is the error message that would result in
an incorrect reference of a module in the service.xml.

During the process of initializing the repository listener, the respective services' modules
get loaded. But, as your module does not appear, it would fail giving such an error.

N.B. The same error message could be resulted due to certain other errors that occur during
the process of initializing the repository listener.

Please note that axis2_http_server requires you to have service.xml files that have references
only modules that have been deployed.

> When a service is loaded with a module ref in service.xml, but without that module deployed
then axis2 engine start fail
> ------------------------------------------------------------------------------------------------------------------------
>
>                 Key: AXIS2C-622
>                 URL: https://issues.apache.org/jira/browse/AXIS2C-622
>             Project: Axis2-C
>          Issue Type: Bug
>          Components: core/deployment
>            Reporter: Damitha Kumarage
>
> When a service is loaded with a module ref in service.xml, but without that module deployed
then axis2 engine start fail without giving any useful log indication.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


---------------------------------------------------------------------
To unsubscribe, e-mail: axis-c-dev-unsubscribe@ws.apache.org
For additional commands, e-mail: axis-c-dev-help@ws.apache.org


Mime
View raw message