axis-c-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Chris Rose (JIRA)" <j...@apache.org>
Subject [jira] Commented: (AXIS2C-710) pkg-config not detected properly during configure
Date Sat, 27 Oct 2007 06:21:51 GMT

    [ https://issues.apache.org/jira/browse/AXIS2C-710?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel#action_12538173
] 

Chris Rose commented on AXIS2C-710:
-----------------------------------

I can confirm that this issue is present on RHEL3 and Solaris9 as well.  The configure script
fails in both cases.

I didn't go the route that the submitter took; I built a standalone pkg-config 0.22 package
as a pre-compilation step, but it's not an ideal solution.  Moreover, I had to specify the
LIBXML2_* variables anyway, because our libxml2 libraries are in a non-standard location.

Lastly, all of this was despite building with --enable-libxml2=no

> pkg-config not detected properly during configure
> -------------------------------------------------
>
>                 Key: AXIS2C-710
>                 URL: https://issues.apache.org/jira/browse/AXIS2C-710
>             Project: Axis2-C
>          Issue Type: Bug
>          Components: build system (Unix/Linux)
>    Affects Versions: 1.1.0
>         Environment: Red Hat Enterprise Linux 4 with pkgconfig-0.15 RPM installed
>            Reporter: Stefano Pettini
>
> I cannot compile Axis2/C on RHEL4 because:
> checking for LIBXML2... configure: error: The pkg-config script could not be found or
is too old.  Make sure it
> is in your PATH or set the PKG_CONFIG environment variable to the full
> path to pkg-config.
> I don't see the need of version 0.20 or higher, since the installed version, 0.15, is
able to retrieve LIBS and CFLAGS of libxml-2.0 without any problem.
> By the way:
> Alternatively, you may set the environment variables LIBXML2_CFLAGS
> and LIBXML2_LIBS to avoid the need to call pkg-config.
> See the pkg-config man page for more details.
> This doesn't work too, since I manually set those variables, here they are, just copied
from "set" output:
> LIBXML2_CFLAGS=-I/usr/include/libxml2
> LIBXML2_LIBS='-lxml2 -lpthread -lz -lm'
> But configure still try to use the pkg-config utility it doesn't like.
> Upgrading the RPM is not an option, this would require an upgraded C library too.
> I solved modifying the configure script of axiom, lowering the required pkg-config version
from 0.20 to 0.15 and works perfectly. I think this fix should be included in next releases.
> Thank you!
> Stefano

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


---------------------------------------------------------------------
To unsubscribe, e-mail: axis-c-dev-unsubscribe@ws.apache.org
For additional commands, e-mail: axis-c-dev-help@ws.apache.org


Mime
View raw message