axis-c-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Samisa Abeysinghe (JIRA)" <j...@apache.org>
Subject [jira] Commented: (AXIS2C-693) SOAP envelope incorrect
Date Fri, 14 Sep 2007 09:58:32 GMT

    [ https://issues.apache.org/jira/browse/AXIS2C-693?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel#action_12527433
] 

Samisa Abeysinghe commented on AXIS2C-693:
------------------------------------------

I captured the messages with ethereal and here are the messages:

POST /axis2/services/math HTTP/1.1

User-Agent: Axis2/C

Content-Length: 248

Content-Type: application/soap+xml;charset=UTF-8

Host: localhost:9090



<soapenv:Envelope xmlns:soapenv="http://www.w3.org/2003/05/soap-envelope"><soapenv:Header/><soapenv:Body><ns1:add
xmlns:ns1="http://ws.apache.org/axis2/services/math"><param1>40</param1><param2>8</param2></ns1:add></soapenv:Body></soapenv:Envelope>HTTP/1.1
200 OK

Content-Type: application/soap+xml;charset=UTF-8

Content-Length: 207



<soapenv:Envelope xmlns:soapenv="http://www.w3.org/2003/05/soap-envelope"><soapenv:Header/><soapenv:Body><ns1:result
xmlns:ns1="http://axis2/test/namespace1">48</ns1:result></soapenv:Body></soapenv:Envelope>


So the messages seem to be complete. Also note that I have tested Axis2/C with .NET and Axis2/Java
and they seem to work fine. Please double check your installation, seems that there is some
local problem on your machine

> SOAP envelope incorrect
> -----------------------
>
>                 Key: AXIS2C-693
>                 URL: https://issues.apache.org/jira/browse/AXIS2C-693
>             Project: Axis2-C
>          Issue Type: Bug
>          Components: core/engine
>    Affects Versions: 1.0.0, 1.1.0
>         Environment: Ubuntu 7.0.4 on i386
>            Reporter: Akos Gabriel
>            Priority: Blocker
>
> See the following TCP dump of a call to math service with math client
> POST /axis2/services/echo HTTP/1.1
> User-Agent: Axis2/C
> Content-Length: 262
> Content-Type: application/soap+xml;charset=UTF-8
> Host: localhost:9090
> <soapenv:Envelope xmlns:soapenv="http://www.w3.org/2003/05/soap-envelope"><soapenv:Header></soapenv:Header><soapenv:Body><ns1:echoString
xmlns:ns1="http://ws.apache.org/axis2/c/samples"><text>Hello World!</text></ns1:echoString></soapenv:Body></soapenv:Envelope
> HTTP/1.1 200 OK
> Content-Type: application/soap+xml;charset=UTF-8
> Content-Length: 262
> <soapenv:Envelope xmlns:soapenv="http://www.w3.org/2003/05/soap-envelope"><soapenv:Header></soapenv:Header><soapenv:Body><ns1:echoString
xmlns:ns1="http://ws.apache.org/axis2/c/samples"><text>Hello World!</text></ns1:echoString></soapenv:Body></soapenv:Envelope
> Obviously the closing ">" from the </soapenv:Envelope> tag is missing. Because
of that the product can't interoperate with anything else (what expects a well-formed XML)...
> I think this is a critical error.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


---------------------------------------------------------------------
To unsubscribe, e-mail: axis-c-dev-unsubscribe@ws.apache.org
For additional commands, e-mail: axis-c-dev-help@ws.apache.org


Mime
View raw message