axis-c-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jamie Lyon (JIRA)" <j...@apache.org>
Subject [jira] Commented: (AXIS2C-665) "axis2_svc_client_get_last_response_has_fault" return 0 even when there is really soap fault returned.
Date Wed, 15 Aug 2007 10:09:30 GMT

    [ https://issues.apache.org/jira/browse/AXIS2C-665?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel#action_12519915
] 

Jamie Lyon commented on AXIS2C-665:
-----------------------------------

I'm not sure about the original poster, but it seems to me as though this problems only occurs
when rampart is enabled with a required incoming security header. From what I can determine,
when rampart doesn't detect a security header attached to the fault it puts a message in the
log. I'm not sure whether this will then affect the outcome from get_last_response_has_fault.
But I can certainly make the fault appear and disappear simply by enabling and disabling rampart
in axis2.xml.

> "axis2_svc_client_get_last_response_has_fault" return 0 even when there is really soap
fault returned.
> ------------------------------------------------------------------------------------------------------
>
>                 Key: AXIS2C-665
>                 URL: https://issues.apache.org/jira/browse/AXIS2C-665
>             Project: Axis2-C
>          Issue Type: Bug
>          Components: core/clientapi
>    Affects Versions: 1.0.0
>         Environment: Windodw Server 2003, English Version, Microsoft Visual C++.net 2005,
Intel Petium D CPU 3.0G dual core, 2G memory 
>            Reporter: Rock Wang
>            Priority: Critical
>
> "axis2_svc_client_get_last_response_has_fault" return 0 even when there is really soap
fault returned.
> I have used "axiom_node_to_string" to print the returned soap body by the peer service(which
is developed by Java and deployed by JBoss), and it reads:
> <env:Fault xmlns:env="http://schemas.xmlsoap.org/soap/envelope/"><faultcode>env:Client</faultcode><faultstring>Cannot
find child element: String_1</faultstring></env:Fault>
> But "axis2_svc_client_get_last_response_has_fault" really returns 0 on it. :-(

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


---------------------------------------------------------------------
To unsubscribe, e-mail: axis-c-dev-unsubscribe@ws.apache.org
For additional commands, e-mail: axis-c-dev-help@ws.apache.org


Mime
View raw message