axis-c-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Minifie, Todd" <todd.mini...@cgi.com>
Subject Axis or Axis2 for AIX 5.2
Date Wed, 18 Jul 2007 13:00:49 GMT
 

Hello Rajika

 

Do you know if anyone has:

 

      1. Axis C++ v1.6 Client working on an AIX v5.2 system?

      2. Compiled Axis2 Linux source on an AIX v5.2 system?

 

I am in the middle of an important project that has our team modifying
our IBM XL C/C++ v8.0 application to authenticate on an LDAP server. I
have been provided with a WSDL for the LDAP Web Service and I plan on
using Axis/Axis2 C/C++ stubs to make the HTTP call to the web service. 

 

 

 

Here is the exception I am currently getting using Axis C++ v1.6

 

 

************ Start Display Current Environment ************

Axis C++ libraries built on Aug 24 2006 at 18:37:16

Runtime trace produced on Wed Jul 18 08:42:04 2007

 

PATH=/home/tminifie/bin:/cb/dev/rel1.0/bl1235/bin:/usr/bin:/etc:/usr/sbi
n:/usr/ucb:/usr/bin/X11:/sbin:/usr/java131/jre/bin:/usr/java

131/bin:/usr/vac/bin:/usr/vacpp/bin:/cb/bin:/usr/idebug:.:/usr/local/bin
:/usr/sqr/db2/bin:/usr/sqr/jre/jre116/bin:/usr/teamc/bin:/cb

/bin:/cb/devbin:/usr/bin:/etc:/usr/sbin:/usr/ucb:/home/tminifie/bin:/usr
/bin/X11:/sbin:usr/dt/bin/:/usr/ibmcxx/include:.:/home/db2v8

c1/sqllib/bin:/home/db2v8c1/sqllib/adm:/home/db2v8c1/sqllib/misc

LIBPATH=/usr/lib:/lib:/opt/freeware/lib:/usr/xerces-c_2_6_0-aix_510-xlc_
60_040810/lib:.:/usr/sqr/jre/jre116/lib/aix/native_threads:/

usr/teamc/lib:/usr/teamc/lib:/usr/sqr/jre/jre116/lib/aix/native_threads:
/home/tminifie/AXIS/axis-c-1.6-AIX-trace-bin/:/home/tminifie

/AXIS/axis-c-1.6-AIX-trace-bin/lib/axis:/home/db2v8c1/sqllib/lib:.:/home
/tminifie/lib:/cb/dev/rel1.0/bl1235/lib

LD_LIBRARY_PATH=/home/db2v8c1/sqllib/lib

AXISCPP_DEPLOY=/home/tminifie/AXIS/axis-c-1.6-AIX-trace-bin/deploy

PWD=/home/tminifie

CLASSPATH=/home/db2v8c1/sqllib/java/db2java.zip:/home/db2v8c1/sqllib/jav
a/db2jcc.jar:/home/db2v8c1/sqllib/java/sqlj.zip:/home/db2v8c

1/sqllib/function:/home/db2v8c1/sqllib/java/db2jcc_license_cu.jar:.

NLSPATH=/usr/lib/nls/msg/%L/%N:/usr/lib/nls/msg/%L/%N.cat

USERNAME=tminifie

LANG=en_US

LOGIN=tminifie

LOGNAME=tminifie

USER=tminifie

************* End Display Current Environment *************

[18/07/2007 08:42:04:659 EDT] 1 - I -------------- Config File settings
START ----------------

[18/07/2007 08:42:04:659 EDT] 1 AxisConfig > getAxisConfProperty
@3011bf48,[00000000] <....>

[18/07/2007 08:42:04:659 EDT] 1 AxisConfig < getAxisConfProperty
@3011bf48,@1 <null>

[18/07/2007 08:42:04:659 EDT] 1 - I AXCONF_WSDDFILEPATH = NULL

[18/07/2007 08:42:04:659 EDT] 1 AxisConfig > getAxisConfProperty
@3011bf48,[00000001] <....>

[18/07/2007 08:42:04:659 EDT] 1 AxisConfig < getAxisConfProperty
@3011bf48,@2 "/home/tminifie/AXIS/axis-c-1.6-AIX-trace-bin/deploy/l

og/AxisLog"

[18/07/2007 08:42:04:659 EDT] 1 - I AXCONF_LOGPATH =
/home/tminifie/AXIS/axis-c-1.6-AIX-trace-bin/deploy/log/AxisLog

[18/07/2007 08:42:04:659 EDT] 1 AxisConfig > getAxisConfProperty
@3011bf48,[00000002] <....>

[18/07/2007 08:42:04:659 EDT] 1 AxisConfig < getAxisConfProperty
@3011bf48,@2 "/home/tminifie/AXIS/axis-c-1.6-AIX-trace-bin/deploy/l

og/AxisClientLog"

[18/07/2007 08:42:04:659 EDT] 1 - I AXCONF_CLIENTLOGPATH =
/home/tminifie/AXIS/axis-c-1.6-AIX-trace-bin/deploy/log/AxisClientLog

[18/07/2007 08:42:04:659 EDT] 1 AxisConfig > getAxisConfProperty
@3011bf48,[00000003] <....>

[18/07/2007 08:42:04:659 EDT] 1 AxisConfig < getAxisConfProperty
@3011bf48,@1 <null>

[18/07/2007 08:42:04:659 EDT] 1 - I AXCONF_CLIENTWSDDFILEPATH = NULL

[18/07/2007 08:42:04:659 EDT] 1 AxisConfig > getAxisConfProperty
@3011bf48,[00000004] <....>

[18/07/2007 08:42:04:659 EDT] 1 AxisConfig < getAxisConfProperty
@3011bf48,@2 "/home/tminifie/AXIS/axis-c-1.6-AIX-trace-bin/deploy"

[18/07/2007 08:42:04:659 EDT] 1 - I AXCONF_AXISHOME =
/home/tminifie/AXIS/axis-c-1.6-AIX-trace-bin/deploy

[18/07/2007 08:42:04:659 EDT] 1 AxisConfig > getAxisConfProperty
@3011bf48,[00000005] <....>

[18/07/2007 08:42:04:659 EDT] 1 AxisConfig < getAxisConfProperty
@3011bf48,@2 "libhttp_transport.a"

[18/07/2007 08:42:04:659 EDT] 1 - I AXCONF_TRANSPORTHTTP =
libhttp_transport.a

[18/07/2007 08:42:04:659 EDT] 1 AxisConfig > getAxisConfProperty
@3011bf48,[00000006] <....>

[18/07/2007 08:42:04:659 EDT] 1 AxisConfig < getAxisConfProperty
@3011bf48,@1 <null>

[18/07/2007 08:42:04:659 EDT] 1 - I AXCONF_TRANSPORTSMTP = NULL

[18/07/2007 08:42:04:660 EDT] 1 AxisConfig > getAxisConfProperty
@3011bf48,[00000007] <....>

[18/07/2007 08:42:04:660 EDT] 1 AxisConfig < getAxisConfProperty
@3011bf48,@2 "libaxis_xmlparser.a"

[18/07/2007 08:42:04:660 EDT] 1 - I AXCONF_XMLPARSER =
libaxis_xmlparser.a

[18/07/2007 08:42:04:660 EDT] 1 AxisConfig > getAxisConfProperty
@3011bf48,[00000008] <....>

[18/07/2007 08:42:04:660 EDT] 1 AxisConfig < getAxisConfProperty
@3011bf48,@2 "server name"

[18/07/2007 08:42:04:660 EDT] 1 - I AXCONF_NODENAME = server name

[18/07/2007 08:42:04:660 EDT] 1 AxisConfig > getAxisConfProperty
@3011bf48,[00000009] <....>

[18/07/2007 08:42:04:660 EDT] 1 AxisConfig < getAxisConfProperty
@3011bf48,@2 "listen port"

[18/07/2007 08:42:04:660 EDT] 1 - I AXCONF_LISTENPORT = listen port

[18/07/2007 08:42:04:660 EDT] 1 AxisConfig > getAxisConfProperty
@3011bf48,[0000000A] <....>

[18/07/2007 08:42:04:660 EDT] 1 AxisConfig < getAxisConfProperty
@3011bf48,@2 "Unknown"

[18/07/2007 08:42:04:660 EDT] 1 - I AXCONF_SSLCHANNEL_HTTP = Unknown

[18/07/2007 08:42:04:660 EDT] 1 AxisConfig > getAxisConfProperty
@3011bf48,[0000000B] <....>

[18/07/2007 08:42:04:660 EDT] 1 AxisConfig < getAxisConfProperty
@3011bf48,@2 "libhttp_channel.a"

[18/07/2007 08:42:04:660 EDT] 1 - I AXCONF_CHANNEL_HTTP =
libhttp_channel.a

[18/07/2007 08:42:04:660 EDT] 1 AxisConfig > getAxisConfProperty
@3011bf48,[0000000C] <....>

[18/07/2007 08:42:04:660 EDT] 1 AxisConfig < getAxisConfProperty
@3011bf48,@1 <null>

[18/07/2007 08:42:04:660 EDT] 1 - I AXCONF_SECUREINFO = NULL

[18/07/2007 08:42:04:660 EDT] 1 - I -------------- Config File settings
END OF ----------------

[18/07/2007 08:42:04:660 EDT] 1 XMLParserFactory > initialize

[18/07/2007 08:42:04:660 EDT] 1 AxisConfig > getAxisConfProperty
@3011bf48,[00000007] <....>

[18/07/2007 08:42:04:660 EDT] 1 AxisConfig < getAxisConfProperty
@3011bf48,@2 "libaxis_xmlparser.a"

[18/07/2007 08:42:04:660 EDT] 1 XMLParserFactory > loadLib

[18/07/2007 08:42:04:776 EDT] 1 - I ------------>

[18/07/2007 08:42:04:776 EDT] 1 - I Failed to load parser
'libaxis_xmlparser.a' within server engine:

[18/07/2007 08:42:04:776 EDT] 1 - I                  Error Message='A
file or directory in the path name does not exist.'

[18/07/2007 08:42:04:776 EDT] 1 - I                 Error Code='2'

[18/07/2007 08:42:04:776 EDT] 1 - I                  Load lib error='A
file or directory in the path name does not exist.'

[18/07/2007 08:42:04:776 EDT] 1 AxisEngineException >
AxisEngineException @2ff20bc8,29, "Failed to load parser
'libaxis_xmlparser.a'

 within server engine: "

[18/07/2007 08:42:04:776 EDT] 1 AxisEngineException >
getMessageForExceptionCode @2ff20bc8,29

[18/07/2007 08:42:04:776 EDT] 1 AxisEngineException <
getMessageForExceptionCode @2ff20bc8,"DLOPEN FAILED in loading parser
library"

[18/07/2007 08:42:04:776 EDT] 1 AxisEngineException >
getMessageForExceptionCode @2ff20bc8,29

[18/07/2007 08:42:04:776 EDT] 1 AxisEngineException <
getMessageForExceptionCode @2ff20bc8,"DLOPEN FAILED in loading parser
library"

[18/07/2007 08:42:04:776 EDT] 1 AxisEngineException <
AxisEngineException @2ff20bc8

[18/07/2007 08:42:04:821 EDT] 1 - X initialize_module @3 caught "..."

[18/07/2007 08:42:04:821 EDT] 1 - > done_initializing

[18/07/2007 08:42:04:821 EDT] 1 - < done_initializing

 

 

 

 

The libaxis_xmlparser.a does not exist anywhere under the
"axis-c-1.6-AIX-trace-bin" directory structure........

 

 

 

Your feedback will be greatly appreciated.

 

Thanks,

 

 

 

Todd Minifie

Senior Analyst, Banking Services

CGI

905 762-2800

ext. 4024


Mime
View raw message