axis-c-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dinesh Premalal <xydin...@gmail.com>
Subject Re: [Axis2] ssl_stream.h and ssl_utils.h are missing
Date Thu, 08 Feb 2007 04:45:54 GMT
Hi Michael,

Michael.Senkbeil@SIZ.DE writes:
> after successful compiling with the headers from svn (i had to do a little
> change on axis2_ssl_utils_initialize_ctx in ssl_utils.h since in 0.96 there
> is no second parameter), I'm now trying to run it with apache web server
> 2.2.4 and mod_ssl.
I'm sure that you configure apache with mod_ssl accurately.
>
> The echo sample works fine with normal http access to the apache (request
> to http://localhost/axis2/services/echo on my PC). Accessing via https does
> not work with echo. In the echo.log I found:
> [Wed Feb 07 12:07:50 2007] [error] ..\..\samples\client\echo\echo.c(134)
> Stub invoke FAILED: Error code: 3 :: Blocking invocation expects response
> There are no log entries at serverside, so it seems that the client is not
> able to send the request to the server. AXIS2_SSL_CA_FILE ist set to the
> pem-file I fetched from the server by using openssl as described in the
> Axis2/C manual.
hmm..It gave me a segfault (with current svn head) :(
> The server certificate is self made (for testing purpuses) generated by
> openssl, so there is no official signing authority (like verisign)
> involved. May this cause the problem? 
I don't think so.
>Or do I have to link some additional
> ssl libraries to the client?
AFAIK axis2c manual guide you correctly.

thanks,
Dinesh
-- 
Dinesh Premalal
dinesh@wso2.com
WSO2, Inc.; http://www.wso2.com/
GPG Key ID : A255955C
GPG Key Finger Print : C481 E5D4 C27E DC34 9257  0229 4F44 266E A255 955C


---------------------------------------------------------------------
To unsubscribe, e-mail: axis-c-dev-unsubscribe@ws.apache.org
For additional commands, e-mail: axis-c-dev-help@ws.apache.org


Mime
View raw message