axis-c-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Nicholas Hart <nh...@real.com>
Subject axiscpp problems
Date Wed, 15 Nov 2006 17:53:03 GMT

I'm having trouble getting axiscpp to work.  I tried the 1.6b version, 
but my wsdl uses nillable elements and it produced code that doesn't 
compile.  the 1.6 "current" version seems to have this problem fixed 
(although there were a couple minor syntax errors in the generated code 
which I fixed by hand).  my test app seems to link ok, but when I run 
it, it throws an exception that it can't find the XML parser--even 
though I'm pretty sure I followed the rest of the install directions 
correctly:

Axis Exception : DLOPEN FAILED in loading parser library Failed to load 
parser '
AxisXMLParser.dll' within server engine:
                  Error Message='The specified module could not be found.
'
                 Error Code='126'
                  Load lib error=''

I'm pretty much stuck and have spent the last couple days spinning my 
wheels on this--I've tried building from source with no luck and even 
tried on linux, which I thought might be easier--but I'm encountering 
problems there as well.

What's the state of this project?  should I be using axis2c instead?  Is 
all this complicated setup (eg: axiscpp.conf, setting paths, etc) 
necessary for a simple client?



---------------------------------------------------------------------
To unsubscribe, e-mail: axis-c-dev-unsubscribe@ws.apache.org
For additional commands, e-mail: axis-c-dev-help@ws.apache.org


Mime
View raw message