axis-c-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dinesh Premalal <xydin...@gmail.com>
Subject Re: [Axis2][VOTE]Axis2/C 0.95 Release Plan
Date Wed, 18 Oct 2006 10:52:49 GMT
Hi Andrew,

please see my comments in line

"Andrew Borley" <ajborley@gmail.com> writes:

> Hi all,
>
> I'm trying to verify AXIS2C-209 against the trunk code, but
> unfortunately I'm still failing to build from the trunk (see trace
> below).
>
> Instead I took 0.94 and built and ran the test_service sample that was
> attached to that jira. I still get a server crash on Windows with the
> message: Unhandled exception at 0x7c918fea in axis2_http_server.exe:
> 0xC0000005: Access violation writing location 0x00000010.
>
> This happens after the test service code returns control to Axis. The steps are:
> - client calls to service
> - service is invoked and calls the math service
> - response is returned from the math service
> - AXIS2_SVC_CLIENT_FREE is called & is successful
> - the response axiom node is returned to Axis by the test_service_invoke method
> - server crashes
I compiled and run this sample in my Linux box without any problem.But
I didn't get a chance to run on windows machine

>
> I expect I will see the same error in 0.95 code & I'm working to get
> this built. Does anyone else get this behaviour?
>
> The failure when building trunk:
> make[5]: Entering directory `/home/ajborley/workspace/Axis2C/woden/src/wsdl'
> if /bin/sh ../../libtool --tag=CC --mode=compile gcc -DHAVE_CONFIG_H
> -I. -I. -I../.. -I../../include -I ../../../util/include -I
> ../../../axiom/include -I ../../../xml_schema/include    -g -O2
> -D_LARGEFILE64_SOURCE -ansi -Wall -Wno-implicit-function-declaration
> -Werror -MT import.lo -MD -MP -MF ".deps/import.Tpo" -c -o import.lo
> import.c; \
> then mv -f ".deps/import.Tpo" ".deps/import.Plo"; else rm -f
> ".deps/import.Tpo"; exit 1; fi
> gcc -DHAVE_CONFIG_H -I. -I. -I../.. -I../../include -I
> ../../../util/include -I ../../../axiom/include -I
> ../../../xml_schema/include -g -O2 -D_LARGEFILE64_SOURCE -ansi -Wall
> -Wno-implicit-function-declaration -Werror -MT import.lo -MD -MP -MF
> .deps/import.Tpo -c import.c  -fPIC -DPIC -o .libs/import.o
> cc1: warnings being treated as errors
> import.c: In function 'woden_import_to_wsdl_ref':
> import.c:128: warning: dereferencing type-punned pointer will break
This warning get when try to build with gcc version 4.1. This issue
 was reported at axis2c-241. We are in a process of fixing it.

Though it is not recommended , I would say two methods to try out.

1. Try with gcc version 4.0 :(

2. You can switch off -Werror in woden.

in woden/configure.ac

    CFLAGS="$CFLAGS -ansi -Wall -Wno-implicit-function-declaration
    -Werror"
 
change it to 

    CFLAGS="$CFLAGS -ansi -Wall -Wno-implicit-function-declaration"

thanks,
Dinesh

PS: I appreciate if we could continue this conversation with other
subject other than  "Re: [Axis2][VOTE]Axis2/C 0.95 Release Plan"
just to avoid confusion

---------------------------------------------------------------------
To unsubscribe, e-mail: axis-c-dev-unsubscribe@ws.apache.org
For additional commands, e-mail: axis-c-dev-help@ws.apache.org


Mime
View raw message