axis-c-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "William D. Strathearn" <william.strathe...@ask.com>
Subject Re: simple_axis_server Trace Output Disappearance
Date Fri, 22 Sep 2006 21:12:47 GMT
I see now.  Because the source package already includes code with the
traces inserted, you can enable them to be un-hidden during compilation
by modifying this section of build.xml

    <target name="build" depends="initialize"
     description="Build runtime libraries, WSDL2Ws tool and API
Documentation">
        <antcall target="buildAll" inheritall="true"/>
    </target>

to be: 

    <target name="build" depends="initialize"
     description="Build runtime libraries, WSDL2Ws tool and API
Documentation">
        <property name="trace" value="true"/>
        <antcall target="buildAll" inheritall="true"/>
    </target>

Thanks for the fast response.  Much appreciated!

On Fri, 2006-09-22 at 09:37 +0100, John Hawkins wrote:

> 
> You have to build the code with trace options so that trace is
> embedded. if you look in build.xml you will see various targets e.g.
> BuildWithTrace. 
> 
> 
> 
> 
> 
> 
> "William Strathearn"
> <william.strathearn@ask.com> 
> 
> 22/09/2006 01:22 
>          Please respond to
>   "Apache AXIS C Developers List"
>     <axis-c-dev@ws.apache.org>
> 
> 
> 
> 
>                To
> <axis-c-dev@ws.apache.org> 
>                cc
> 
>           Subject
> simple_axis_server Trace Output Disappearance
> 
> 
> 
> 
> 
> 
> 
> 
> Can anyone think of a reason that all output to the file specified by
> LogPath would cease to be output?  I have a sucessfully operating
> simple_axis_server built from the latest 1.6b, which does not output
> anything to the trace file specified.  Not even the startup pre-amble
> is printed. 
> 
> The odd thing is that if I swap the *.so files I built with those
> found in the binary distribution downloaded on the same day, the trace
> statements are output to the log file just fine.  I have not modified
> any of the downloaded source, only build.common.properties.  Is there
> something special I need to do in the build.xml file to enable trace
> definitions? 
> 
> --
> Bill
> 

--
Bill

Mime
View raw message