axis-c-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Franz Fehringer <...@isogmbh.de>
Subject Re: [jira] Commented: (AXISCPP-986) ANT Build failed
Date Tue, 25 Jul 2006 12:54:07 GMT
To me the latest Java errors simply say, that the compiler exes 
(especially the resource compiler rc) are not found.

Greetings

Franz

Adrian Dick (JIRA) schrieb:
>     [ http://issues.apache.org/jira/browse/AXISCPP-986?page=comments#action_12423326
] 
>             
> Adrian Dick commented on AXISCPP-986:
> -------------------------------------
>
> Hi,
>
> It really isn't clear to me how you're trying to compile the code, but there seem to
be a lot of inconsistencies.
> I've already mentioned the problems I found using the current source code with VC++ 8,
for which updates will need to be produced.
>
> Your linker error (on VC++ 8), sounds like you're trying to compile into a windows application,
rather than a DLL.
>
> The errors you have when compiling VC++ 6 really don't make any sense.
> It looks like it is failing to link with the Call object when you're compiling the AxisServer
DLL.  But the call object should only exist within the Axis Client DLL, you shouldn't be seeing
any references to it from within the server DLL.
>
>
> As for your latest Java errors, which version of Axis Java are you using?
>
>   
>> ANT Build failed
>> ----------------
>>
>>                 Key: AXISCPP-986
>>                 URL: http://issues.apache.org/jira/browse/AXISCPP-986
>>             Project: Axis-C++
>>          Issue Type: Bug
>>          Components: Build - ANT
>>    Affects Versions:  1.6 Final
>>         Environment: Win XP
>>            Reporter: Manfred Pauli
>>         Attachments: log.txt, log1.txt
>>
>>
>> Hi!
>> I tried to build Axis c++ for a new platform (windows mobile). But first I tried
to build it for WinXP. But when executing the ant command, I get this errors:
>> Buildfile: build.xml
>> pre-init:
>> set-platform-specifics:
>> checkIfDebug:
>> initialize:
>> build:
>> compile:
>> compileClient:
>> compileAxisClient:
>> buildVersionResource:
>>    [delete] Deleting 1 files from C:\Dokumente und Einstellungen\Manfred\Desktop\Axis
Sourc
>> e\build
>>      [copy] Copying 1 file to C:\Dokumente und Einstellungen\Manfred\Desktop\Axis
Source\bu
>> ild
>> BUILD FAILED
>> C:\Dokumente und Einstellungen\Manfred\Desktop\Axis Source\build.xml:245: The following
err
>> or occurred while executing this line:
>> C:\Dokumente und Einstellungen\Manfred\Desktop\Axis Source\build.xml:233: The following
err
>> or occurred while executing this line:
>> C:\Dokumente und Einstellungen\Manfred\Desktop\Axis Source\build.xml:96: The following
erro
>> r occurred while executing this line:
>> C:\Dokumente und Einstellungen\Manfred\Desktop\Axis Source\build\buildClient.xml:10:
The fo
>> llowing error occurred while executing this line:
>> C:\Dokumente und Einstellungen\Manfred\Desktop\Axis Source\build.xml:82: Execute
failed: ja
>> va.io.IOException: CreateProcess: rc /fo "C:\Dokumente und Einstellungen\Manfred\Desktop\Ax
>> is Source/build/version.res" "C:\Dokumente und Einstellungen\Manfred\Desktop\Axis
Source/bu
>> ild/version.temp.rc" error=2
>> Total time: 2 seconds
>> What's wrong here?
>> Thanx for help!
>> Greetings
>>     
>
>   


Mime
View raw message