axis-c-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Manfred Pauli (JIRA)" <axis-c-...@ws.apache.org>
Subject [jira] Commented: (AXISCPP-986) ANT Build failed
Date Mon, 24 Jul 2006 18:37:14 GMT
    [ http://issues.apache.org/jira/browse/AXISCPP-986?page=comments#action_12423118 ] 
            
Manfred Pauli commented on AXISCPP-986:
---------------------------------------

Now I get this error:

MSVCRT.lib(crtexew.obj) : error LNK2019: Reference on unsolved extern symbol "_WinMain@16"
in Funktion "___tmainCRTStartup".

I think this has to do something with the entry point? Do I have to set any further linker
flags?

Moreover I'm going to compile with C++ 6.0 tomorrow, but I don't know, if I can build a library
for the Windows mobile platform with that compiler...

Greetings,
Manfred



> ANT Build failed
> ----------------
>
>                 Key: AXISCPP-986
>                 URL: http://issues.apache.org/jira/browse/AXISCPP-986
>             Project: Axis-C++
>          Issue Type: Bug
>          Components: Build - ANT
>    Affects Versions:  1.6 Final
>         Environment: Win XP
>            Reporter: Manfred Pauli
>         Attachments: log.txt
>
>
> Hi!
> I tried to build Axis c++ for a new platform (windows mobile). But first I tried to build
it for WinXP. But when executing the ant command, I get this errors:
> Buildfile: build.xml
> pre-init:
> set-platform-specifics:
> checkIfDebug:
> initialize:
> build:
> compile:
> compileClient:
> compileAxisClient:
> buildVersionResource:
>    [delete] Deleting 1 files from C:\Dokumente und Einstellungen\Manfred\Desktop\Axis
Sourc
> e\build
>      [copy] Copying 1 file to C:\Dokumente und Einstellungen\Manfred\Desktop\Axis Source\bu
> ild
> BUILD FAILED
> C:\Dokumente und Einstellungen\Manfred\Desktop\Axis Source\build.xml:245: The following
err
> or occurred while executing this line:
> C:\Dokumente und Einstellungen\Manfred\Desktop\Axis Source\build.xml:233: The following
err
> or occurred while executing this line:
> C:\Dokumente und Einstellungen\Manfred\Desktop\Axis Source\build.xml:96: The following
erro
> r occurred while executing this line:
> C:\Dokumente und Einstellungen\Manfred\Desktop\Axis Source\build\buildClient.xml:10:
The fo
> llowing error occurred while executing this line:
> C:\Dokumente und Einstellungen\Manfred\Desktop\Axis Source\build.xml:82: Execute failed:
ja
> va.io.IOException: CreateProcess: rc /fo "C:\Dokumente und Einstellungen\Manfred\Desktop\Ax
> is Source/build/version.res" "C:\Dokumente und Einstellungen\Manfred\Desktop\Axis Source/bu
> ild/version.temp.rc" error=2
> Total time: 2 seconds
> What's wrong here?
> Thanx for help!
> Greetings

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: http://issues.apache.org/jira/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

---------------------------------------------------------------------
To unsubscribe, e-mail: axis-c-dev-unsubscribe@ws.apache.org
For additional commands, e-mail: axis-c-dev-help@ws.apache.org


Mime
View raw message