axis-c-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Adrian Dick <adrian.d...@uk.ibm.com>
Subject RE: Segmentation fault
Date Mon, 27 Mar 2006 14:13:49 GMT
Hi,

I see you mentioned earlier in this thread that you have built the Axis C++
libraries yourself.
Which build target did you use?

See here, for details on ensureing trace is included at build time:
http://ws.apache.org/axis/cpp/antbuild-guide.html#EnablingTraceAndDebug

Regards,
Adrian
_______________________________________
Adrian Dick (adrian.dick@uk.ibm.com)


"Dubi Lego" <dlego@allot.com> wrote on 27/03/2006 14:51:50:

> I enabled the trace in the configuration file but no log file was
> generated.
> Is there anything else to do?
>
> -----Original Message-----
> From: Adrian Dick [mailto:adrian.dick@uk.ibm.com]
> Sent: Monday, March 27, 2006 10:05 AM
> To: Apache AXIS C Developers List
> Subject: Re: Segmentation fault
>
> Hi,
>
> Can you enable trace, as this will allow us to more accurately diagnose
> the
> problem.
> See step 4. of
> http://ws.apache.org/axis/cpp/install-guide.html#Installing_Client for
> detail on setting the configuration file.
>
> Regards,
> Adrian
> _______________________________________
> Adrian Dick (adrian.dick@uk.ibm.com)
>
>
> "Dubi Lego" <dlego@allot.com> wrote on 26/03/2006 12:10:23:
>
> > Hi all!
> >
> > I compiled axis c++ client with ant and when I run it crashed.
> > I try to debug it with gdb and the output is:
> >
> > [Thread debugging using libthread_db enabled]
> >
> > [New Thread 16384 (LWP 20889)]
> >
> > Program received signal SIGSEGV, Segmentation fault.
> >
> > [Switching to Thread 16384 (LWP 20889)]
> >
> > 0x400a175c in axiscpp::SoapSerializer::serializeBasicArray ()
> >
> >    from /users/dlego/SOAP_AXIS/juniper_project/axis-c-1.6b-Linux-
> > trace-bin/deplo
> > y/lib/libaxis_client.so
> >
> > Does anybody know what can be the reason?
> >
> > Thank in advanced,
> >
>


Mime
View raw message