axis-c-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Dushshantha Chandradasa (JIRA)" <axis-c-...@ws.apache.org>
Subject [jira] Commented: (AXISCPP-743) SoapDeSerializer::getAttribute does not use namespace
Date Mon, 01 Aug 2005 10:16:35 GMT
    [ http://issues.apache.org/jira/browse/AXISCPP-743?page=comments#action_12317307 ] 

Dushshantha Chandradasa commented on AXISCPP-743:
-------------------------------------------------

It seems to me that SoapDeSerializer::getElement method is also not using the namespace although
it recieves it as a parameter.

And at the stub level, we send NULL for parameter. 

xsd__int v0 = *(pIWSDZ->getElementAsInt("in0",0));

Mark,
why do we need check for namespace here? Could you please explain the way we should use namespace
here. 

Dushshantha

> SoapDeSerializer::getAttribute does not use namespace
> -----------------------------------------------------
>
>          Key: AXISCPP-743
>          URL: http://issues.apache.org/jira/browse/AXISCPP-743
>      Project: Axis-C++
>         Type: Bug
>   Components: Client - Deserialization
>     Reporter: Mark Whitlock

>
> While looking through the code I noticed that SoapDeSerializer::getAttribute does not
use the namespace that it passed. This looks like a bug to me. I imagine I could recreate
the problem by deserializing two attributes which have the same name but different namespaces.
If this is not a bug, then namespace should not be passed to SoapDeSerializer::getAttribute.
I have not checked whether there are other methods with similar bugs.

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators:
   http://issues.apache.org/jira/secure/Administrators.jspa
-
For more information on JIRA, see:
   http://www.atlassian.com/software/jira


Mime
View raw message