axis-c-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Chinthana Danapala (JIRA)" <axis-c-...@ws.apache.org>
Subject [jira] Commented: (AXISCPP-663) Deserializing a Complex Element
Date Wed, 10 Aug 2005 09:49:35 GMT
    [ http://issues.apache.org/jira/browse/AXISCPP-663?page=comments#action_12318299 ] 

Chinthana Danapala commented on AXISCPP-663:
--------------------------------------------

I have problem in generating code from WSDL2ws tool. It gives follwing error.

org.apache.axis.wsdl.wsdl2ws.WrapperFault: unregisterd type {http://xml.apache.org/xml-soap}Element
refered
        at org.apache.axis.wsdl.wsdl2ws.WSDL2Ws.createParameterInfo(Unknown Sour
ce)
        at org.apache.axis.wsdl.wsdl2ws.WSDL2Ws.addRPCStyleInputMessageToMethodI
nfo(Unknown Source)
        at org.apache.axis.wsdl.wsdl2ws.WSDL2Ws.setMethodInfo(Unknown Source)
        at org.apache.axis.wsdl.wsdl2ws.WSDL2Ws.getServiceInfo(Unknown Source)
        at org.apache.axis.wsdl.wsdl2ws.WSDL2Ws.generateWrappers(Unknown Source)

        at org.apache.axis.wsdl.wsdl2ws.WSDL2Ws.main(Unknown Source)

Code generation failed. Please see errors above. 

It seems to me http://xml.apache.org/xml-soap not there.

> Deserializing a Complex Element
> -------------------------------
>
>          Key: AXISCPP-663
>          URL: http://issues.apache.org/jira/browse/AXISCPP-663
>      Project: Axis-C++
>         Type: Bug
>   Components: Client - Deserialization
>     Versions: 1.5 Final
>  Environment: Windows with apache tomcat and Apache SOAP
>     Reporter: shijith lal
>  Attachments: syncadminstub.wsdl
>
>  I am using the Axis C++ 1.5 Final version in my product. In that I want to recieve a
complex object. Hence I write a custom deserializer function. In that deserializer function
I am calling the "getAnyObject()" function of Deserializer. I am expecting a XML. For normal
case it is working smooth. But if my response XML consist of any special charector ( '<','>','&',
etc). The return value of "getAnyObject()" is not a escaped string. Hence I could not parse
this string. Is it a expected behaviour. If it si so, Then how can I solve my problem??

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators:
   http://issues.apache.org/jira/secure/Administrators.jspa
-
For more information on JIRA, see:
   http://www.atlassian.com/software/jira


Mime
View raw message