axis-c-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Rangika Mendis <rang...@opensource.lk>
Subject Re: Attachments
Date Thu, 05 May 2005 07:59:41 GMT
Hi John,

When I typed the following command 

ant -f test.xml -Ddir.xmlParser=/usr/local/xerces-c-src_2_6_0/lib -
Ddir.release=/home/rangika/checkout_May04/obj/package/axis-c-1.6.0-
Linux-bin -Dtest.name=SimpleRef > rangika.log


I got the following output in the log.

Buildfile: test.xml

pre-init:

preInitializeTest:

overrideTest:

set-platform-specifics:

checkIfDebug:

initialize:

initializeTest:

compileMonitorUtility:

compile:

package:

production:

initializeLogFile:

setListType:

setIndividual:
     [echo] setIndividual SimpleRef

setFromList:

setAll:

setTestList:

runTests:

loadXMLProperties:
     [echo] Loading XML file /home/rangika/checkout_May04/apache/ws-
axis/c/tests/auto_build/testcases/tests/SimpleRef.xml

setTestName:

setTestDesc:

setTestCode:

setClientLang:

setTestWsdl:

setTestEndpoint:

setTestExpected:

setTestExpectedRequest:

setHandlerDirectory:

setHandlerService:

setHandlersPresent:

setTestPort:

setPropertiesForTest:

cleanTest:
   [delete] Deleting
directory /home/rangika/checkout_May04/obj/test/generated/cpp/SimpleRef

checkIfRequestFile:

setPropertiesForThisTest:

compileTestClient:

callCompileStaticClient:

setLanguage:

generateStubs:
    [mkdir] Created
dir: /home/rangika/checkout_May04/obj/test/generated/cpp/SimpleRef
     [java] log4j:WARN No appenders could be found for logger
(org.apache.axis.i18n.ProjectResourceBundle).
     [java] log4j:WARN Please initialize the log4j system properly.

     [java] Code generation completed.


copyClientCode:
     [copy] Copying 1 file
to /home/rangika/checkout_May04/obj/test/generated/cpp/SimpleRef

copyStubClient:

copyDynamicClient:

getClient:

compileStaticClient:
       [cc] 3 total files to be compiled.
       [cc] Starting link

callCompileLinkedClient:

compileClient:

validateClientCompilationIfBuilding:
     [echo] SimpleRef - Client Compilation - PASSED

validateClientCompilationIfNotBuilding:

validateClientCompilation:

checkIfDebug:

createConfigurationFile:

createStartOfWSDDFile:

compileTestHandlers:

createEndOfWSDDFile:

updateConfigurationWithClientWSDDEntry:

compileHandlers:

buildTest:

executeTestRun:

setResultExpectations:
     [copy] Copying 1 file
to /home/rangika/checkout_May04/obj/test/generated/cpp/SimpleRef

setRequestExpectations:

setExpectations:

setEndpoint:

setForMonitor:

setVerbatim:

checkIfEndpointSet:

setForNoMonitor:

setTestArgs:

executeTest:
startMonitor:
     [echo] Starting monitor forwarding to localhost:5555
     [echo] MONITOR OUTPUT=
     [echo] Running Test SimpleRef http://localhost:13260/axis/Ref
[stopwatch] [SimpleRef.timer: 0.592 sec]
     [echo] SimpleRef - Execution Time - 0.592 sec

stopMonitor:

validateTestClient:
     [echo] SimpleRef - Client Execution - FAILED

validateMessageOnWire:

validateTest:

runTest:

displayAllResults:
     [echo] Test Results
     [echo]
     [echo] SimpleRef - Client Compilation - PASSED
     [echo] SimpleRef - Execution Time - 0.592 sec
     [echo] SimpleRef - Client Execution - FAILED

testSuite:

BUILD SUCCESSFUL
Total time: 7 seconds

Then I gave the testPort = 5555 in build/build.Linux.Properties & put
target port as 80 & listen port 5555 in the TCP mon to see the response.
The response is as follows


HTTP/1.1 404 Not Found
Date: Wed, 04 May 2005 13:11:48 GMT
Server: Apache/2.0.53 (Unix)
Content-Length: 281
Content-Type: text/html; charset=iso-8859-1

<!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN">
<html><head>
<title>404 Not Found</title>
</head><body>
<h1>Not Found</h1>
<p>The requested URL /axis/Ref was not found on this server.</p>
<hr>
<address>Apache/2.0.53 (Unix) Server at 127.0.0.1 Port 5555</address>
</body></html>



Regds
Rangika






On Thu, 2005-05-05 at 08:30 +0100, John Hawkins wrote:
> 
> Hi Rangika, 
> 
> which bit of the ANT build is not working for you? If you need any
> help please feel free to post it up and we'll take a look. 
> 
> 
> 
> 
> Rangika Mendis
> <rangika@opensource.lk> 
> 
> 05/05/2005 08:10 
>          Please respond to
>   "Apache AXIS C Developers List"
> 
> 
> 
> 
>                To
> Apache AXIS C
> Developers <axis-
> c-
> dev@ws.apache.org> 
>                cc
> 
>           Subject
> Attachments
> 
> 
> 
> 
> 
> 
> 
> 
> Hi All,
> 
> I tested attachments (on server side)in Windows using VC (Not using
> ANT
> build) & it's working.
> 
> I couldn't test with the ANT build because ANT is not building
> properly. 
> 
> Once ANT is working I can check in Windows & Linux.Till then I'm not
> committing the code since I don't know whether the changes might crash
> the CVS.
> 
> Regds
> Rangika
> 
> 
> 


Mime
View raw message