axis-c-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
Subject RE: [jira] Commented: (AXISCPP-612) cannot compile Apache2Transport.cpp
Date Mon, 11 Apr 2005 09:22:25 GMT
Hi Samisa

Thanks for your reply. I knew that my pathnames are confusing, because I only intended to
work with axis.
I wrote a small sample client but when invoking axis (binary distribution) it simply core
Therefore I tried to build axis on my own to be able to debug.

For this purpose I also built Xerces and Apache2 (both successfully).

I have installed Apache2 under /home/wenglech/projects/axis/install 
so I think --with-apache2=/home/wenglech/projects/axis/install should be fine.

Before using 1.4 I tried 1.5 and I got exactly the same compilation error, that is why I thought
going back one version!!!

Do you have any further idea? Because we are quite keen on using axis instead of gsoap what
we have used before.

Best regards


IT Equities
Investment Bank Switzerland
Mailing address: P.O. Box, CH-8098 Zurich
Europastrasse 2, Opfikon
Tel. 	+41- 1-239 55 74
Fax: 	+41- 1-239 50 90
GSM: 	+41-76-327 64 11 <>

-----Original Message-----
From: Samisa Abeysinghe (JIRA) []
Sent: Montag, 11. April 2005 10:01
To: Wengler, Christian
Subject: [jira] Commented: (AXISCPP-612) cannot compile

     [ ]
Samisa Abeysinghe commented on AXISCPP-612:

Looks like you have set the apache2 home incorrect:
Is your apache2 located here?

Also, 1.4 is not outdated and 1.5 is the new release. Why not try 1.5? Please note that with
1.5, make may not work. You have to use ant.


> cannot compile Apache2Transport.cpp
> -----------------------------------
>          Key: AXISCPP-612
>          URL:
>      Project: Axis-C++
>         Type: Bug
>   Components: Transport (axis3)
>     Versions: 1.4 Final
>  Environment: redhat Linux 2.4.21-9.0.1.EL , gcc version 3.2.3 20030502 (Red Hat Linux
>     Reporter: christian wengler
>     Priority: Blocker

> Hi
> I cannot compile axis src distribution. (the compiler errors are reported "down under")
> I have 
> a locally built xerces-c:
> /home/wenglech/projects/axis/src-dist/xerces-c-src_2_6_0
> a locally built apache2,
> made under
> /home/wenglech/projects/axis/src-dist/httpd-2.1.3-beta
> and installed under
> /home/wenglech/projects/axis/install   (not very good named location I agree)
> after having set the variables 
> AXISCPP_HOME=/home/wenglech/projects/axis/src-dist/axis-c-src-1-4-linux
> AXISCPP_DEPLOY=/home/wenglech/projects/axis/src-dist/install
> LD_LIBRARY_PATH=/home/wenglech/projects/axis/src-dist/xerces-c-src_2_6_0/lib:/home/wenglech/projects/axis/src-dist/install/lib::/opt/eclipse
> and exported them
> (I basically followed
> I ran configure as
> ./configure --prefix=$AXISCPP_DEPLOY --with-apache2=/home/wenglech/projects/axis/install
--with-xercesc=/home/wenglech/projects/axis/src-dist/xerces-c-src_2_6_0 --enable-axis3=yes
> then
> make
>  g++ -DHAVE_CONFIG_H -I. -I. -I../../.. -I/home/wenglech/projects/axis/install/include
-I../../../include -Wall -Wshadow -DENABLE_AXISTRACE -g -O2 -MT Apache2Transport.lo -MD -MP
-MF .deps/Apache2Transport.Tpo -c Apache2Transport.cpp  -fPIC -DPIC -o .libs/Apache2Transport.o
> Apache2Transport.cpp: In member function `virtual void 
>    Apache2Transport::setTransportProperty(AXIS_TRANSPORT_INFORMATION_TYPE, 
>    const char*)':
> Apache2Transport.cpp:97: `ap_table_set' undeclared (first use this function)
> Apache2Transport.cpp:97: (Each undeclared identifier is reported only once for 
>    each function it appears in.)
> Apache2Transport.cpp: In member function `virtual const char* 
>    Apache2Transport::getTransportProperty(const char*)':
> Apache2Transport.cpp:215: `ap_table_elts' undeclared (first use this function)
> make[4]: *** [Apache2Transport.lo] Error 1
> make[4]: Leaving directory `/home/wenglech/projects/axis/src-dist/axis-c-src-1-4-linux/src/server/apache2'
> Best regards
> Christian
> PS
> the same happens also with axis-c-src-1-5-alpha-linux

This message is automatically generated by JIRA.
If you think it was sent incorrectly contact one of the administrators:
If you want more information on JIRA, or have a bug to report see:

Visit our website at

This message contains confidential information and is intended only 
for the individual named.  If you are not the named addressee you 
should not disseminate, distribute or copy this e-mail.  Please 
notify the sender immediately by e-mail if you have received this 
e-mail by mistake and delete this e-mail from your system.

E-mail transmission cannot be guaranteed to be secure or error-free 
as information could be intercepted, corrupted, lost, destroyed, 
arrive late or incomplete, or contain viruses.  The sender therefore 
does not accept liability for any errors or omissions in the contents 
of this message which arise as a result of e-mail transmission.  If 
verification is required please request a hard-copy version.  This 
message is provided for informational purposes and should not be 
construed as a solicitation or offer to buy or sell any securities or 
related financial instruments.

View raw message