axis-c-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jeff Clary <jcl...@euronetworldwide.com>
Subject RE: SimpleAxisServer will not start
Date Fri, 29 Apr 2005 15:00:39 GMT
Samisa,

After trying your document step by step and getting SimpleAxisServer to at
least start (haven't tried the clients yet), I went back and compared that
success carefully with my earlier attempt.  It turns out I originally had
bad paths in my axiscpp.conf for XMLParser, Transport_http, Channel_HTTP,
and Channel_HTTP_SSL.  Thanks for the help.

Jeff


-----Original Message-----
From: Samisa Abeysinghe [mailto:SAbeysinghe@virtusa.com]
Sent: Friday, April 29, 2005 12:46 AM
To: Apache AXIS C Developers List
Subject: RE: SimpleAxisServer will not start


Given the numerous complaints on Simple Axis Server not working, I got a
fresh machine (never touched by Axis C++) and installed Axis C++ from
scratch and documented the process of how to get it running.

PFA the document

The operating system on the machine was Windows 2003 server.

HTH

Thanks,
Samisa...

-----Original Message-----
From: Samisa Abeysinghe [mailto:SAbeysinghe@virtusa.com] 
Sent: Friday, April 29, 2005 9:21 AM
To: Apache AXIS C Developers List; dims@apache.org
Subject: RE: SimpleAxisServer will not start

As mentioned in the reply thread
http://marc.theaimsgroup.com/?t=111333000000001&r=1&w=2, Xerces DLL is
the culprit most of the time. However, as you have mentioned, you seem
to have this on the PATH. I tried running simple axis server without
Xerces dll on my PATH and I get the same error as you get. When I put
this back, things work OK.

Additionally do you have W:\SimpleAxisServer\Axis\conf\server.wsdd file
as specified by axiscpp.conf in the correct location? If this is
missing, you tend to get a similar error but the error will also say
that it cannot locate the server.wsdd file.

To verify that the settings are correct, before running simple axis
server on a new shell, try echo %AXISCPP_DEPLOY% to and %PATH% to make
sure that the settings include what is required by Axis C++.

Thanks,
Samisa...





-----Original Message-----
From: Davanum Srinivas [mailto:davanum@gmail.com] 
Sent: Friday, April 29, 2005 12:10 AM
To: Apache AXIS C User List; Apache AXIS C Developers List
Subject: Re: SimpleAxisServer will not start

I had posted the same problem and did not get a reply :(

-- dims

On 4/28/05, Jeff Clary <jclary@euronetworldwide.com> wrote:
> Folks,
> 
> I am having trouble getting Axis C++ SimpleAxisServer to start under
Windows XP.  It gives the following message:
> 
> This application has requested the Runtime to terminate it in an
unusual way.
> Please contact the application's support team for more information.
> 
> I followed the instructions at
http://ws.apache.org/axis/cpp/wininstall-guide.html, in the
"Installation with Simple Axis Server" section.  In particular:
> 
> 1. I created the folder W:\SimpleAxisServer.
> 2,3,4. I extracted axis-c-1-5-win32.zip copied the deploy folder to
W:\SimpleAxisServer, and renamed it Axis.
> 5,6.  I set AXISCPP_DEPLOY=W:\SimpleAxisServer\Axis and added
W:\SimpleAxisServer\Axis\lib to my PATH variable.
> 7. I copied SimpleAccessServer.exe from the extracted files to
W:\SimpleAxisServer.
> 8,9,10. I copied the required DLLs to W:\SimpleAxisServer\Axis\lib,
including xerces-c_2_2_0.dll.  (I renamed AxisXMLParser_Xerces.dll to
AxisXMLParser.dll as instructed.)
> 10. I edited W:\SimpleAxisServer\Axis\axiscpp.conf as follows:
> 
> LogPath:W:\SimpleAxisServer\log\AxisLog
> WSDDFilePath:W:\SimpleAxisServer\Axis\conf\server.wsdd
> XMLParser:W:\SimpleAxisServer\lib\AxisXMLParser.dll
> Transport_http:W:\SimpleAxisServer\lib\HTTPTransport.dll
> Channel_HTTP:W:\SimpleAxisServer\lib\HTTPChannel.dll
> Channel_HTTP_SSL:W:\SimpleAxisServer\lib\HTTPSSLChannel.dll
> 
> 11. I opened a command prompt in W:\SimpleAxisServer and ran the
command "SimpleAxisServer 80".  No joy.  I retried it with port 8080.
Following the note in the instructions, I copied AxisClient.dll to
W:\SimpleAxisServer.  In fact, I copied *all* the DLLs from the Axis bin
directory to W:\SimpleAxisServer.
> 
> I checked the W:\SimpleAxisServer\log\AxisLog file for errors, but it
is empty.  (I created it empty just in case Axis needed an existing log
file.)
> 
> Sorry if this is a FAQ kind of thing, but I searched the lists without
finding anything obvious.  I did find something dated 2004-07-06 saying
SimpleAxisServer was out of date and has problems.  Could that still be
the case?
> 
> Thanks,
> Jeff
> 


-- 
Davanum Srinivas - http://webservices.apache.org/~dims/

Mime
View raw message