axis-c-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "silkevonberg (JIRA)" <axis-c-...@ws.apache.org>
Subject [jira] Commented: (AXISCPP-613) Proxy Error
Date Wed, 20 Apr 2005 11:52:23 GMT
     [ http://issues.apache.org/jira/browse/AXISCPP-613?page=comments#action_63279 ]
     
silkevonberg commented on AXISCPP-613:
--------------------------------------

Hello Samisa,

thanks for your answer.  

We have already implemented the following method for the proxy-authentification. 

void stub::SetAuthorizationHeader ( char* m_pcUsername , char *m_pcPasswort )
{
    char* cpUsernamePassword = new char[strlen( m_pcUsername) + strlen( m_pcPasswort  )
										   + 2];
    strcpy( cpUsernamePassword, m_pcUsername );
    strcat( cpUsernamePassword, ":" );
    strcat( cpUsernamePassword, m_pcPasswort );
    int len = apr_base64_encode_len (strlen(cpUsernamePassword));
     
    AxisChar* base64Value = new AxisChar[len + 1];
    len = apr_base64_encode_binary ( base64Value, (const unsigned char*)cpUsernamePassword,
strlen 
                                                                                   (cpUsernamePassword));
  
    std::string strValue = "Basic ";
    strValue += base64Value;
  
    this->setTransportProperty( "Proxy-Authorization", strValue.c_str());
    delete [] cpUsernamePassword;
    delete [] base64Value;

With this , we can pass through the proxy, but can´t call the webservice-method. What´s
wrong. Is there anything else we have to do ??

Thnx SilkevonBerg

P.S. were can we get the Version 1.6 ?? There is no link on the project page anymore.

> Proxy Error
> -----------
>
>          Key: AXISCPP-613
>          URL: http://issues.apache.org/jira/browse/AXISCPP-613
>      Project: Axis-C++
>         Type: Bug
>   Components: Client - Engine
>     Versions: 1.5 Final
>  Environment: Win32, MS Visual C++ 6.X
>     Reporter: silkevonberg

>
> I´ll try to use the SetProxy-Method stub.setproxy(proxyserver,port), but the proxy always
get no authentification.
> There is no Proxy-Authentification topic in the message, when I looked with the tcpmon-tool.
So I get always the message "HTTPTransport exception: HTTP transport error proxy Authentification
required"
> I use basic authentification.
> In the document "UsingProxy.txt" from Samisa there is nothing else mentioned
> Greetings Silke

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators:
   http://issues.apache.org/jira/secure/Administrators.jspa
-
For more information on JIRA, see:
   http://www.atlassian.com/software/jira


Mime
View raw message