axis-c-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Rangika Mendis" <rang...@opensource.lk>
Subject Re: attachments
Date Tue, 19 Apr 2005 06:36:28 GMT

Hi Samisa,


I tested attachment support with the socket client in February and it worked. But now when
I tried to see whether it's working I get the following soap message in the TCP Monitor.

Request - (these are the contents of the socket client)

POST /axis/servlet/AxisServlet HTTP/1.0
Content-Type: multipart/related; type="text/xml"; start="<1505912FEDEB53D396BC22103DA3A51A>";
  boundary="----=_Part_0_6349096.1105418692309"
Accept: application/soap+xml, application/dime, multipart/related, text/*
User-Agent: Axis/1.2beta
Host: 127.0.0.1:5555
Cache-Control: no-cache
Pragma: no-cache
SOAPAction: ""
Content-Length:980
SOAPAction: "AttService#EchoAttachment"


------=_Part_0_6349096.1105418692309
Content-Type: text/xml; charset=UTF-8
Content-Transfer-Encoding:8-bit
Content-Id: <1505912FEDEB53D396BC22103DA3A51A>

<?xml version="1.0" encoding="UTF-8"?>
<soapenv:Envelope xmlns:soapenv="http://schemas.xmlsoap.org/soap/envelope/" xmlns:xsd="http://www.w3.org/2001/XMLSchema"
xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
 <soapenv:Body>
<ns1:EchoAttachment soapenv:encodingStyle="http://schemas.xmlsoap.org/soap/encoding/" xmlns:ns1="urn:EchoAttachmentsService">
    <id1 xsi:type="xsd:string">000001233</id1>
    <id2 xsi:type="xsd:string">000001234</id2>
   </ns1:EchoAttachment>
 </soapenv:Body>
</soapenv:Envelope>
------=_Part_0_6349096.1105418692309
Content-Type: text/xml
Content-Transfer-Encoding: base64
Content-Id: <000001233>

SGVsbG8=

------=_Part_0_6349096.1105418692309
Content-Type: text/xml
Content-Transfer-Encoding: base64
Content-Id: <000001234>

R29vZA==

------=_Part_0_6349096.1105418692309

Response - 

HTTP/1.1 400 Bad Request

Date: Tue, 19 Apr 2005 04:43:05 GMT

Server: Apache/2.0.48 (Win32)

Content-Length: 412

Connection: close

Content-Type: text/html; charset=iso-8859-1

<!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN">

<html><head>

<title>400 Bad Request</title>

</head><body>

<h1>Bad Request</h1>

<p>Your browser sent a request that this server could not understand.<br />

Request header field is missing ':' separator.<br />

<pre>

start="&lt;1505912FEDEB53D396BC22103DA3A51A&gt;";

</pre>

</p>

<hr />

<address>Apache/2.0.48 (Win32) Server at abc Port 80</address>

</body></html>

Can anyone help me on this???????

Regards,
Rangika
  ----- Original Message ----- 
  From: Samisa Abeysinghe 
  To: Apache AXIS C Developers List 
  Sent: Tuesday, April 19, 2005 10:14 AM
  Subject: RE: attachments


  So as I understand, you write the raw SOAP message directly to the server.

   

  Still I think this client would help us when implementing Client side attachments.

  Please attach this client to a Jira issue.

   

  Thanks,

  Samisa.

   

   

  -----Original Message-----
  From: Rangika Mendis [mailto:rangika@opensource.lk] 
  Sent: Tuesday, April 19, 2005 9:56 AM
  To: Apache AXIS C Developers List
  Subject: Re: attachments

   

  Hi John,

   

  I'm sorry for the earlier reply.

  The client that I'm using is a socket program that's just used for testing.It will just
send couple of attachments to the server port &

  & then the engine will handle the attachments.

   

  Rangika

   

   

   

    ----- Original Message ----- 

    From: Rangika Mendis 

    To: Apache AXIS C Developers List 

    Sent: Tuesday, April 19, 2005 9:45 AM

    Subject: Re: attachments

     

    Hi John,

     

    Yes it's a cpp client.

     

    Rangika

      ----- Original Message ----- 

      From: John Hawkins 

      To: Apache AXIS C Developers List 

      Sent: Monday, April 18, 2005 10:26 PM

      Subject: Re: attachments

       


      Hi Rangika, 
      so, is this a CPP client? 





            "Rangika Mendis" <rangika@opensource.lk> 

            18/04/2005 13:36 

                  Please respond to
                  "Apache AXIS C Developers List"
                 

           To
                 "Apache AXIS C Developers List" <axis-c-dev@ws.apache.org> 
                 
                  cc
                  
                 
                  Subject
                 Re: attachments
                 

             

                   
                  
                 

           




      Hi Samisa, 
        
      I will test attachments with a sample client & if it's working will send it to you.

        
        
        
      Rangika 
      ----- Original Message ----- 
      From: Samisa Abeysinghe 
      To: Apache AXIS C Developers List 
      Sent: Monday, April 18, 2005 10:42 AM 
      Subject: RE: attachments 

      Hi Rangika, 
                  How can we test those? Do we have a sample? 
      Thanks, 
      Samisa. 
        
      -----Original Message-----
      From: Rangika Mendis [mailto:rangika@opensource.lk] 
      Sent: Monday, April 18, 2005 10:44 AM
      To: Apache AXIS C Developers List
      Subject: Re: attachments 
        
      Hi John, 
        
      Server side ws-attachments is complete. 
        
      Regards, 
      Rangika 
      ----- Original Message ----- 
      From: John Hawkins 
      To: axis-c-dev@ws.apache.org 
      Sent: Monday, April 11, 2005 7:30 PM 
      Subject: attachments 
        

      Hi Folks, 

      how is the attachment support coming along? 

Mime
View raw message