axis-c-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "sanjaya singharage" <sanja...@opensource.lk>
Subject Re: problem when running the ant script services.xml
Date Thu, 17 Mar 2005 07:53:19 GMT
sorry,

this is taken as follows "${dir.test.generated}/server/${serviceLang}/${serviceName}/${serviceName}".
(where properties starting with service is taken from the service XML files in ws-axis\c\tests\auto_build\testcases\tests\server)

where dir.test.generated is taken from build.PLATFORM.properties file.

Yes, if necessary we can use a different property for this.

sanjaya.
  ----- Original Message ----- 
  From: Samisa Abeysinghe 
  To: Apache AXIS C Developers List 
  Sent: Thursday, March 17, 2005 1:46 PM
  Subject: RE: problem when running the ant script services.xml


  Hi Sanjaya,

  From where is "D:\san\works\checkouts\obj\test\generated\server\" picked from?

   

  Can we using something like:

  dir.test.server.generated = ${dir.obj}/test/server/generated

  from properties file, similar to the use of 

  dir.test.generated = ${dir.obj}/test/generated

  in client test framework.

   

  Thanks,

  Samisa.

   

  -----Original Message-----
  From: sanjaya singharage [mailto:sanjayas@opensource.lk] 
  Sent: Thursday, March 17, 2005 1:22 PM
  To: Apache AXIS C Developers List
  Subject: Re: problem when running the ant script services.xml

   

  "Axis" is meant to be the deployment folder. i.e. where AXISCPP_DEPLOY points to. The services.xml
builds only the webservices and the relevant binaries are generated under D:\san\works\checkouts\obj\test\generated\server\.


   

  sanjaya.

    ----- Original Message ----- 

    From: Samisa Abeysinghe 

    To: Apache AXIS C Developers List 

    Sent: Thursday, March 17, 2005 12:58 PM

    Subject: RE: problem when running the ant script services.xml

     

    There is yet another problem as well. It copies files to C:\Axis and not to C:\obj as
the test.xml does (the client test script)

     

    I would like both the scripts to use the same higher level folder structure.

     

    Thanks,

    Samisa.

     

    -----Original Message-----
    From: Dushshantha Chandradasa [mailto:dchandradasa@virtusa.com] 
    Sent: Thursday, March 17, 2005 12:33 PM
    To: Apache AXIS C Developers List
    Subject: problem when running the ant script services.xml

     

    Hi,

     

    The following error was occurred when running the services.xml ant script. 

     

    prepareDeployment:

         [copy] Copying 25 files to C:\Axis

         [copy] Copying 3 files to C:\Axis\lib

     

    BUILD FAILED

    C:\axiscpp\ws-axis\c\services.xml:24: Warning: Could not find file C:\xerces-c2_

    2_0-win32\bin\xerces-c_2.dll to copy.

     

     

    The file name should be xerces-c_2_2_0.dll 

     

    Regards,

     

    Marcus Dushshantha Chandradasa

    Associate  Software Engineer

    Virtusa (Pvt) Ltd.

    dchandradasa@virtusa.com

    Mob:  0714867441

     

     

     

Mime
View raw message