axis-c-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "sanjaya singharage" <sanja...@opensource.lk>
Subject Re: SimpleAxisServer build fails on windows
Date Tue, 30 Nov 2004 07:53:32 GMT
The change make the project compile. But can't get from cvs yet.

sanjaya.
----- Original Message -----
From: "Samisa Abeysinghe" <samisa_abeysinghe@yahoo.com>
To: "Apache AXIS C Developers List" <axis-c-dev@ws.apache.org>
Sent: Tuesday, November 30, 2004 1:15 PM
Subject: Re: SimpleAxisServer build fails on windows


> I've put this patch in CVS. Please test with a freash checkout.
> Thanks,
> Samisa...
>
> --- Samisa Abeysinghe <samisa_abeysinghe@yahoo.com> wrote:
>
> > Sanjaya,
> >     In case you are still having the problem...
> > In Axis.cpp, I changed
> >
> > extern "C" int uninitialize_module () {}
> > to
> > extern "C" {
> > STORAGE_CLASS_INFO
> > int uninitialize_module () {}
> > }
> >
> > Do the same for initialize_module ()
> >
> > I dod not commit this because I did not test this on Linux.
> >
> > Thanks,
> > Samisa...
> >
> >
> > sanjaya singharage <sanjayas@opensource.lk> wrote:
> > apprently, the AxisServer.lib does not seem to contain the
> > _initialize_module symbol. Axis.cpp which contains the initialize_module
> > function is included in the AxisServer project. I have tried fix this
but no
> > luck. What could be happening? Any thoughts?
> >
> > sanjaya.
> > ----- Original Message -----
> > From: "sanjaya singharage"
> > To: "Apache AXIS C Developers List"
> > Sent: Saturday, November 27, 2004 7:19 PM
> > Subject: SimpleAxisServer build fails on windows
> >
> >
> > > --------------------Configuration: SimpleAxisServer - Win32
> > > Release--------------------
> > > Compiling...
> > > SimpleAxisServer.cpp
> > > SimpleAxisTransport.cpp
> > > Generating Code...
> > > Linking...
> > > SimpleAxisServer.obj : error LNK2001: unresolved external symbol
> > > _initialize_module
> > > ../../../bin/SimpleAxisServer.exe : fatal error LNK1120: 1 unresolved
> > > externals
> > > Error executing link.exe.
> > >
> > > SimpleAxisServer.exe - 2 error(s), 0 warning(s)
> > >
> > >
> > >
> > >
> >
> >
> >
> >
> > ---------------------------------
> > Do you Yahoo!?
> >  Meet the all-new My Yahoo! - Try it today!
>
>
>
>
> __________________________________
> Do you Yahoo!?
> Yahoo! Mail - Helps protect you from nasty viruses.
> http://promotions.yahoo.com/new_mail
>
>



Mime
View raw message