axis-c-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From axis-c-...@ws.apache.org
Subject [jira] Commented: (AXISCPP-136) Axis generates wrong response for response messages
Date Thu, 14 Oct 2004 05:39:51 GMT
The following comment has been added to this issue:

     Author: Samisa Abeysinghe
    Created: Wed, 13 Oct 2004 10:39 PM
       Body:
I used a WSDL with

<message name="pingResponse">
    <part name="pingReturn" type="tns:pingResult"/>
</message>

and the generated client code reads:

if (AXIS_SUCCESS == m_pCall->invoke())
                {
                        if(AXIS_SUCCESS == m_pCall->checkMessage("pingResponse", "uri:weblogscom"))
                        {
                                pReturn = (pingResult*)m_pCall->getCmplxObject((void*)
Axis_DeSerialize_pingResult, (void*) Axis_Create_pingResult, (void*) Axis_Delete_pingResult,"pingReturn",
0);
                }


and the generated server code reads:

pIWSSZ->createSoapMethod("pingResponse", "uri:weblogscom");
        xsd__string v0 = pIWSDZ->getElementAsString("weblogurl",0);
        xsd__string v1 = pIWSDZ->getElementAsString("weblogname",0);
        if (AXIS_SUCCESS != (nStatus = pIWSDZ->getStatus())) return nStatus;
        try
        {
                pingResult* ret = pWs->ping(v0,v1);
                return pIWSSZ->addOutputCmplxParam(ret, (void*)Axis_Serialize_pingResult,
(void*)Axis_Delete_pingResult, "pingReturn", Axis_URI_pingResult);
        }

This means both the generated clinet and server are correct.
Could this problem be specific to the WSDL file that the reporter has used? (I do not think
so)

May be the problem is solved with the recent fixes.
---------------------------------------------------------------------
View this comment:
  http://issues.apache.org/jira/browse/AXISCPP-136?page=comments#action_54027

---------------------------------------------------------------------
View the issue:
  http://issues.apache.org/jira/browse/AXISCPP-136

Here is an overview of the issue:
---------------------------------------------------------------------
        Key: AXISCPP-136
    Summary: Axis generates wrong response for response messages
       Type: Bug

     Status: Open
   Priority: Critical

    Project: Axis-C++
 Components: 
             Serialization/Deserialization
   Versions:
             1.1 Final
             1.2 Beta
             1.2 Alpha
             1.2 Final
             1.3 Beta

   Assignee: Samisa Abeysinghe
   Reporter: Marcus Tillmanns

    Created: Wed, 25 Aug 2004 3:22 AM
    Updated: Wed, 13 Oct 2004 10:39 PM
Environment: Windows 2000 Apache 2.50

Description:
Axis generates wrong response for well formed WSDL:

    <wsdl:message name="resumeJobResponse">
        <wsdl:part name="resumeJobReturn" type="s:JobState"/>
    </wsdl:message>

Instead of naming the return element "resumeJobReturn", Axis generates "JobState", ignoring
the correct Name of the part.

    <wsdl:message name="resumeJobResponse">
        <wsdl:part name="JobState" type="s:JobState"/>
    </wsdl:message>

Works, but only because now both (name and type) have the same name.




---------------------------------------------------------------------
JIRA INFORMATION:
This message is automatically generated by JIRA.

If you think it was sent incorrectly contact one of the administrators:
   http://issues.apache.org/jira/secure/Administrators.jspa

If you want more information on JIRA, or have a bug to report see:
   http://www.atlassian.com/software/jira


Mime
View raw message