axis-c-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Valentin Kuznetsov <vkuz...@yahoo.com>
Subject first Linux RPMs are ready
Date Fri, 24 Sep 2004 13:11:11 GMT
Hi,
I made first attempt to get all pieces together and
you
can find first RPM at
http://www.lns.cornell.edu/~vk/axis/

Here my comments:
1) It's first attemp, don't expect that everything
will work (actually I only made them and didn't test).
I'll appreciate if people will try to install them and
leave feedback
2) Those RPMs based on axis-c-1-2 release. To fulfill
RPM structure I rename tar ball to axis-c-1.2.tar.gz
and assigned 1.2 as a version number for axis-c
package
3) I made dependencies on expat, expat-devel, xerces,
xerces-devel, httpd and httpd-devel RPMs. You may find
those RPMs at the same location
4) I modified axis-c code to avoid any environment
settings such as EXPAT_HOME, XERCESC_HOME and purely
rely on system headers/libraries installed by other
packages. 
5) Two header files has been changed:
src/xml/expat/XMLParserExpat.h
replace <expat/expat.h> to <expat.h>
src/server/apache2/Apache2Transport.h
replace <apache2_0/...>
to <httpd/...> and
<apr-0/...>
I add to configure.ac
-I/usr/include/apr-0
option to include apr-0 headers, the httpd package
actually depends on them.
6) I'm not yet throw away expat and choose libwww as
trasport. It's just first attempt and proof that it
works. Later we will agree what should come.
7) RPM will install everything into /usr/local/Axis
it's also need to be agreed.
8) RPM will require to put some Description,etc. and
if anyone will provide them I'll put them into RPMs.

Finally I'll appreciate if you'll put those RPMs in
your area for everybody downloads, since I'll need to
clean-up my space soon.

Enjoy,
rpm -qpliR <package.rpm> will give you full content of
RPM.

Valentin.
P.S. All of them are made on Fedora FC2.
P.S.S. I only put axis and xercesc RPM since I made
them myself, all others you need to find on a web. On
Fedora it's trivial with yum.
yum install expat-devel-1.95.7-1.1
httpd-devel-2.0.50-2.1



		
_______________________________
Do you Yahoo!?
Declare Yourself - Register online to vote today!
http://vote.yahoo.com

Mime
View raw message