axis-c-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Fred Preston <PREST...@uk.ibm.com>
Subject Re: [jira] Commented: (AXISCPP-138) WSDL2WS tool is still putting '>' into the middle of labels
Date Fri, 27 Aug 2004 13:45:02 GMT




Hi Samisa,
      Just re-ran some of our tests and it looks like we must have had a
version problem as the text before the '>' and the '>' have now gone away!
We will re-check and re-run the remaining tests, but it looks like we had
been testing with yesterday's code.

Regards,

Fred Preston.



                                                                                         
                                              
                      Samisa Abeysinghe                                                  
                                              
                      <samisa_abeysinghe        To:       Apache AXIS C Developers List
<axis-c-dev@ws.apache.org>                      
                      @yahoo.com>               cc:                                   
                                                 
                                                Subject:  Re: [jira] Commented: (AXISCPP-138)
WSDL2WS tool is still putting '>' into    
                      27/08/04 14:20             the middle of labels                    
                                              
                      Please respond to                                                  
                                              
                      "Apache AXIS C                                                     
                                              
                      Developers List"                                                   
                                              
                                                                                         
                                              
                                                                                         
                                              



I took a fresh checkout and tested. And the code is genereted properly (see
below).
Could you please try again (checkout, clean and rebuild).

Samisa...

int Axis_Serialize_BenchDataType(BenchDataType* param,
IWrapperSoapSerializer* pSZ, bool bArray =
false)
{
        if ( param == NULL ) {
         /* TODO : may need to check nillable value*/
        pSZ->serializeAsAttribute("xsi:nil", 0, (void*)&(xsd_boolean_true),
XSD_BOOLEAN);
         pSZ->serialize(">", NULL);
        return AXIS_SUCCESS;
        }
        /* first serialize attributes if any*/
        pSZ->serialize(">", 0);
        /* then serialize elements if any*/
        pSZ->serializeAsElement("count", (void*)&(param->count), XSD_INT);
        pSZ->serializeCmplxArray((Axis_Array*)(&param->infos),
                (void*) Axis_Serialize_BenchBasicDataType, (void*)
Axis_Delete_BenchBasicDataType,
(void*) Axis_GetSize_BenchBasicDataType,
                "infos", Axis_URI_BenchBasicDataType);
        return AXIS_SUCCESS;
}


--- Samisa Abeysinghe <samisa_abeysinghe@yahoo.com> wrote:

> Yes, I fixed this problem tested and commited.
> Let me take a fresh checkout form the CVS and test again.
>
> Samisa...
>
> --- axis-c-dev@ws.apache.org wrote:
>
> > The following comment has been added to this issue:
> >
> >      Author: Fred Preston
> >     Created: Fri, 27 Aug 2004 3:31 AM
> >        Body:
> > Hi Samisa,
> > I have just extracted the code from CVS and rebuilt.  When I run
WSDL2WS I still get the
> > following incorrect stub code...
> >
> > ----------------------------------------------------------------------
> > /*
> >  * This static method serialize a BenchDataType type of object
> >  */
> > int Axis_Serialize_BenchDataType(BenchDataType* param,
IWrapperSoapSerializer* pSZ, bool
> bArray
> > = false)
> > {
> >          if ( param == NULL ) {
> >           /* TODO : may need to check nillable value*/
> >          pSZ->serializeAsAttribute("xsi:nil", 0,
(void*)&(xsd_boolean_true), XSD_BOOLEAN);
> >           pSZ->serialize(">", NULL);
> >          return AXIS_SUCCESS;
> >          }
> >          /* first serialize attributes if any*/
> >          pSZ->serialize(">", 0);
> >          /* then serialize elements if any*/
> >          pSZ->serializeAsElement("count", (void*)&(param->count),
XSD_INT);
> >          pSZ->serializeCmplxArray((Axis_Array*)(&param->infos),
> >                      (void*) Axis_Serialize_BenchBasicDataType, (void*)
Axis_Delete_BenchBasicDataType, (void*)
> > Axis_GetSize_BenchBasicDataType,
> >                      "BenchDataType>infos",
Axis_URI_BenchBasicDataType);
> >          return AXIS_SUCCESS;
> > }
> > ----------------------------------------------------------------------
> > Near the bottom, in the call to pSZ->serializeCmplxArray, the name is
still incorrectly given
> as
> > "BenchDataType>infos".  It SHOULD be just "infos".
> >
> > ---------------------------------------------------------------------
> > View this comment:
> >
http://issues.apache.org/jira/browse/AXISCPP-138?page=comments#action_37854
> >
> > ---------------------------------------------------------------------
> > View the issue:
> >   http://issues.apache.org/jira/browse/AXISCPP-138
> >
> > Here is an overview of the issue:
> > ---------------------------------------------------------------------
> >         Key: AXISCPP-138
> >     Summary: WSDL2WS tool is still putting '>' into the middle of
labels
> >        Type: Bug
> >
> >      Status: Resolved
> >    Priority: Major
> >  Resolution: FIXED
> >
> >     Project: Axis-C++
> >  Components:
> >              WSDL processing
> >    Fix Fors:
> >              1.3 Beta
> >
> >    Assignee: Samisa Abeysinghe
> >    Reporter: Fred Preston
> >
> >     Created: Thu, 26 Aug 2004 4:18 AM
> >     Updated: Fri, 27 Aug 2004 3:31 AM
> > Environment: n/a
> >
> > Description:
> > WSDL2WS tool is still putting '>' into the middle of labels. i.e.
> >
> > WSDL
> > <complexType name="BenchBasicDataType">
> >   <sequence>
> >     :
> >   </sequence>
> > </complexType>
> >
> > </complexType>
> >  <complexType name="BenchDataType">
> >   <sequence>
> >    <element name="count" type="xsd:int"/>
> >    <element maxOccurs="unbounded" name="infos"
type="impl:BenchBasicDataType"/>
> >  </sequence>
> > </complexType>
> >
> > Produces (note the '>' between 'Type' and 'infos'):
> > <BenchDataType>infos>
> > :
> > </BenchDataType>infos>
> >
> >
> > ---------------------------------------------------------------------
> > JIRA INFORMATION:
> > This message is automatically generated by JIRA.
> >
> > If you think it was sent incorrectly contact one of the administrators:
> >    http://issues.apache.org/jira/secure/Administrators.jspa
> >
> > If you want more information on JIRA, or have a bug to report see:
> >    http://www.atlassian.com/software/jira
> >
> >
>
>
>
>
>
> __________________________________
> Do you Yahoo!?
> New and Improved Yahoo! Mail - 100MB free storage!
> http://promotions.yahoo.com/new_mail
>




_______________________________
Do you Yahoo!?
Win 1 of 4,000 free domain names from Yahoo! Enter now.
http://promotions.yahoo.com/goldrush




Mime
View raw message