axis-c-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Aleksander Slominski <>
Subject m_Size vs. __size [Re: returning array of string from service
Date Thu, 03 Jun 2004 17:19:20 GMT wrote:

>>BTW: maybe it would be good idea to have consistent naming for example
>>xsd__base64Binary::__size and xsd__string_Array::m_Size - shouldnt both
>>use m_Size? that makes this method asymmetrical to all other methods
>>handling arrays:
>xsd__xxxx are Axis defined types
>xsd__xxxx_Array are Axis defined array structures.
let me rephrase questions: what is design rationale to have two names 
(m_Size and __size) for essentially the same functionality. moreover i 
think "length" would be better name as you are concerned about number of 
elements in array and not array size in bytes ...

BTW: why did you use double underscore and m_* naming g conventions? i 
do not see in this case how there could be a name conflict and need to 
use such hacks as __name (which should be reserved only for standard libs?)


>>xsd__base64Binary Benchmark1PortType::sendBase64(int length)
>>    xsd__base64Binary arr;
>>    arr.__size = length;
>>    arr.__ptr = new xsd__unsignedByte[length];
>>    for (int i=0; i < length; i++) {
>>        arr.__ptr[i] = (xsd__unsignedByte)i;
>>    }
>>    return arr;
>>The best way to predict the future is to invent it - Alan Kay

The best way to predict the future is to invent it - Alan Kay

View raw message