axis-c-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Susantha Kumara <susan...@opensource.lk>
Subject Re: Stub class changes
Date Mon, 21 Jun 2004 13:54:43 GMT
Fixed.

Thanks for quick testing and reporting the problem.

Susantha
---

On Mon, 2004-06-21 at 09:43, Samisa Abeysinghe wrote:
> Hi Susantha,
>    I set the default parameter value of eProtocol to be HTTP.
>  
>    Now I get yet another problem. You have shifted the logic of creating the header block
to Call
> class. Now the Stub test case that I have written fails. See the stack trace below.
> Program received signal SIGSEGV, Segmentation fault.
> [Switching to Thread 1075313920 (LWP 4902)]
> 0x4005b998 in Call::createHeaderBlock(char*, char*) (this=0x804cd50, pachLocalName=0x804a9aa
> "TestHeader",
>     pachUri=0x804a760 "http://ws.apache.org/axisCppTest/") at Call.cpp:580
> 580         return (m_pIWSSZ->createHeaderBlock (pachLocalName, pachUri));
> Current language:  auto; currently c++
> (gdb) bt
> #0  0x4005b998 in Call::createHeaderBlock(char*, char*) (this=0x804cd50, pachLocalName=0x804a9aa
> "TestHeader",
>     pachUri=0x804a760 "http://ws.apache.org/axisCppTest/") at Call.cpp:580
> #1  0x4005cfd2 in Stub::createSOAPHeaderBlock(char*, char*) (this=0xbfffe7f0,
> pachLocalName=0x804a9aa "TestHeader",
>     pachUri=0x804cd50 "&#65533;\t@") at Stub.cpp:178
> #2  0x08048ee0 in strcpy ()
> #3  0x42015574 in __libc_start_main () from /lib/tls/libc.so.6
> (gdb)
> 
>     Earlier logic was working. But the new logic of yours is giving problems. 
>     Could you please fix this.
> Thanks,
> Samisa...
> 
> 
> 
> 
> --- Samisa Abeysinghe <samisa_abeysinghe@yahoo.com> wrote:
> > Hi Susantha,
> >    You have changed the signature of the signature of Stub constructor from:
> > Stub(const char *pcEndPointUri) to
> > Stub(const char *pcEndPointUri, AXIS_PROTOCOL_TYPE eProtocol)
> > 
> >     This has made the stubBase test case in tesst forlder fail to compile.
> > 
> >     I tried to get the test working, however you have not documented the eProtocol
parameter,
> > and
> > I find it difficult to find what parameter values I should be passing.
> > 
> >    Could you please document the parameter.
> > 
> >     Also, is it a must to specify a protocol? cant we assume a default?
> > 
> > Samisa...
> > 
> > 
> > 		
> > __________________________________
> > Do you Yahoo!?
> > Take Yahoo! Mail with you! Get it on your mobile phone.
> > http://mobile.yahoo.com/maildemo
> > 
> 
> 
> 
> 	
> 		
> __________________________________
> Do you Yahoo!?
> New and Improved Yahoo! Mail - 100MB free storage!
> http://promotions.yahoo.com/new_mail
> 


Mime
View raw message