axis-c-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From dami...@opensource.lk
Subject Re: HTTP chunked problem
Date Wed, 12 May 2004 05:32:07 GMT
Hi Adrian,
I tried to apply the chunk patch and received the following error

patch HttpTransport.cpp HttpTransport.cpp.diff
patching file HttpTransport.cpp
Hunk #1 FAILED at 165.
Hunk #2 FAILED at 319.
Hunk #3 FAILED at 420.
Hunk #4 FAILED at 443.
4 out of 4 hunks FAILED -- saving rejects to file HttpTransport.cpp.rej

I apply the patch with the current version of cvs.
May be the version in the cvs with which diff was taken is different.
Then should I retrieve that version and apply the pactch with that version?.
Then again patch with the current version?.
I thought that this not needed and patch internally handle this.

regds
damitha
>
>
>
>
>
> Hi,
>
> Here's the context diff of the HTTP Chunking patch.
>
> (See attached file: HttpTransport.cpp.diff)
>
> _______________________________________
> Adrian Dick (adrian.dick@uk.ibm.com)
>
>
>
>
>              damitha@opensourc
>              e.lk
>                                                                         To
>              29-04-04 12:19            "Apache AXIS C Developers List"
>                                        <axis-c-dev@ws.apache.org>
>                                                                         cc
>              Please respond to
>               "Apache AXIS C                                       Subject
>              Developers List"          Re: HTTP chunked problem
>
>
>
>
>
>
>
>
>
>
>
> Hi John,
> Please send a context diff(diff -c)
>
> damitha
>>
>>
>>
>> The fix is just going into the base code. I'm not a committor (yet :-).
>> Could someone please say when the fix is in so Cheng Liang can get it.
>>
>> John Hawkins,
>> AspectX architect
>> Web Services for C++ development
>>
>> Tel:
>> Internal:  (7) 24-7131
>> External: (+44 ) (0) 1962 817131
>>
>> Mailpoint 188,
>> IBM UK,
>> Hursley Park,
>> Winchester,
>> UK.
>> SO21 2JN
>>
>>
>>
>>              "cheng liang"
>>              <chengliang2004@h
>>              otmail.com>
> To
>>                                        axis-c-dev@ws.apache.org
>>              29/04/2004 09:10
> cc
>>
>>
> Subject
>>              Please respond to         HTTP chunked problem
>>               "Apache AXIS C
>>              Developers List"
>>
>>
>>
>>
>>
>>
>>
>>
>> Hi, John,
>>
>> I want to get a class from webservice server.
>>
>> I think there is much data in this class. So the length of the xml file
>> got
>>
>> is
>> long. Maybe transfer layer cut this xml file to many parts. The reason
>> why
>> I
>> think so is that I only got the first part of this xml file. It is as
>> follows:
>>
>>
> ------------------------------------------------------------------------------
>
>>
>>
>> 842
>> <?xml version="1.0" encoding="UTF-8"?>
>> <soapenv:Envelope
>> xmlns:soapenv="http://schemas.xmlsoap.org/soap/envelope/"
>>
>> xmln
>> s:xsd="http://www.w3.org/2001/XMLSchema"
>> xmlns:xsi="http://www.w3.org/2001/XMLSc
>> hema-instance">
>>  <soapenv:Body>
>>   <ns1:getUserResponse
>> soapenv:encodingStyle="http://schemas.xmlsoap.org/soap/en
>> coding/"
>> xmlns:ns1="http://10.7.0.97:8080/SysPlatform/services/UserClass">
>>    <ns1:getUserReturn href="#id0"/>
>>   </ns1:getUserResponse>
>>   <multiRef id="id0" soapenc:root="0"
>> soapenv:encodingStyle="http://schemas.xmls
>> oap.org/soap/encoding/" xsi:type="ns2:UsersWS"
>> xmlns:soapenc="http://schemas.xml
>> soap.org/soap/encoding/" xmlns:ns2="urn:BeanService">
>>    <address xsi:type="xsd:string"></address>
>>    <birthday xsi:type="xsd:date">1986-01-01</birthday>
>>    <certificateCategory
>> xsi:type="xsd:string">category</certificateCategory>
>>    <certificateNumber xsi:type
>>
> ------------------------------------------------------------------------------
>
>>
>>
>>
>> Does "842" means the chunk serial number?
>>
>> How I could get follow parts of this xml file?
>>
>> How I got the return class correctly?
>>
>> If you have a fix to Axis C++ on windows, could I get the code first?
>>
>> best,
>>
>> Cheng Liang
>>
>>
>>>From: John Hawkins <HAWKINSJ@uk.ibm.com>
>>>Reply-To: "Apache AXIS C Developers List" <axis-c-dev@ws.apache.org>
>>>To: "Apache AXIS C Developers List" <axis-c-dev@ws.apache.org>
>>>Subject: RE: I think Axis c++ is poor cause no one has idea about this
>> problem
>>>Date: Wed, 28 Apr 2004 09:19:56 +0100
>>>
>>>
>>>
>>>
>>>
>>>We have a fix to this but it is not in the code yet. We tested on
>>> Windows
>>>and it worked fine but Linux had problems so we are not putting it in
>> until
>>>we fix the linux problems.
>>>
>>>
>>>John Hawkins,
>>>AspectX architect
>>>Web Services for C++ development
>>>
>>>Tel:
>>>Internal:  (7) 24-7131
>>>External: (+44 ) (0) 1962 817131
>>>
>>>Mailpoint 188,
>>>IBM UK,
>>>Hursley Park,
>>>Winchester,
>>>UK.
>>>SO21 2JN
>>>
>>>
>>>
>>>              "Susantha Kumara"
>>>              <susantha@opensou
>>>              rce.lk>
>> To
>>>                                        "'Apache AXIS C Developers
>>> List'"
>>>              28/04/2004 04:35          <axis-c-dev@ws.apache.org>
>>>
>> cc
>>>
>>>              Please respond to
>> Subject
>>>               "Apache AXIS C           RE: I think Axis c++ is poor
>>> cause
>>>              Developers List"          no one has idea about this
>>> problem
>>>
>>>
>>>
>>>
>>>
>>>
>>>
>>>
>>>
>>>
>>>Yes this is the HTTP 1.1 chunking problem.
>>>
>>>---
>>>Susantha
>>>
>>>-----Original Message-----
>>>From: Paul Fremantle [mailto:pzf@hursley.ibm.com]
>>>Sent: Tuesday, April 27, 2004 4:44 PM
>>>To: Apache AXIS C Developers List
>>>Subject: Re: I think Axis c++ is poor cause no one has idea about this
>>>problem
>>>
>>>Cheng
>>>
>>>This could be the HTTP 1.1 chunking problem. I believe we fixed this
>>>with Xerces but maybe not expat.
>>>The problem is the initial 222 before the <xml>
>>>
>>>Paul
>>>
>>>cheng liang wrote:
>>>
>>> > hi Susantha,
>>> >
>>> > Thanks for your reply.
>>> >
>>> > I solved this problem by using latest release of Axis C++ (1.1).
>>> >
>>> > But I met another problem.
>>> >
>>> > That is I what to realize a webservice.
>>> >
>>> > Server is using windows xp + Tomcat + Axis.
>>> >
>>> > client is using Apache 1.3.28 + Axis c++ .
>>> >
>>> > I use the WSDL2Ws tools generating client stub code.
>>> >
>>> > I call a method in main() method but could not get the result.
>>> >
>>> > I found the problem lie in int SoapParserExpat::ParseNext()
>>> > {
>>> > ...
>>> > if (XML_STATUS_ERROR == XML_Parse(m_Parser, m_pCurrentBuffer, nChars,
>>> > false))
>>> > ...
>>> > }
>>> >
>>> > That is the return value of XML_Parse(...) is XML_STATUS_ERROR.
>>> >
>>> > I use expat1.95.7.
>>> >
>>> > The payload got from server is :
>>> >
>>>------------------------------------------------------------------------
>>>---------
>>> >
>>> >
>>> > 222
>>> > <?xml version="1.0" encoding="UTF-8"?>
>>> > <soapenv:Envelope
>>> > xmlns:soapenv="http://schemas.xmlsoap.org/soap/envelope/" xmln
>>> > s:xsd="http://www.w3.org/2001/XMLSchema"
>>> > xmlns:xsi="http://www.w3.org/2001/XMLSc
>>> > hema-instance">
>>> > <soapenv:Body>
>>> > <ns1:checkIfHasUserResponse
>>> > soapenv:encodingStyle="http://schemas.xmlsoap.org/
>>> > soap/encoding/"
>>> > xmlns:ns1="http://10.7.0.97:8080/SysPlatform/services/UserClass"
>>> >
>>> >>
>>> > <ns1:checkIfHasUserReturn
>>> > xsi:type="xsd:boolean">false</ns1:checkIfHasUserRet>> > urn>
>>> > </ns1:checkIfHasUserResponse>
>>> > </soapenv:Body>
>>> > </soapenv:Envelope>
>>> > 0
>>> >
>>>------------------------------------------------------------------------
>>>---------
>>> >
>>> >
>>> >
>>> > Why expat could not parse this xml file correctly?
>>> >
>>> > And how to solve this problem?
>>> >
>>> > Thanks.
>>> > Cheng Liang
>>> >
>>> >> From: "Susantha Kumara" <susantha@opensource.lk>
>>> >> Reply-To: "Apache AXIS C Developers List" <axis-c-dev@ws.apache.org>
>>> >> To: "'Apache AXIS C Developers List'" <axis-c-dev@ws.apache.org>
>>> >> Subject: RE: I think Axis c++ is poor cause no one has idea about
>>>this
>>> >
>>> > problem
>>> >
>>> >> Date: Fri, 23 Apr 2004 10:30:29 +0600
>>> >>
>>> >> Hi cheng,
>>> >>
>>> >> I think I replied to this mail earlier too.
>>> >> Anyway could you please use the latest release of Axis C++ (1.1) and
>>>see
>>> >> whether it is working for you ?
>>> >>
>>> >> Please use the latest code generator too (WSDL2Ws tool)
>>> >>
>>> >> Thanks,
>>> >>
>>> >> Susantha.
>>> >>
>>> >> -----Original Message-----
>>> >> From: cheng liang [mailto:chengliang2004@hotmail.com]
>>> >> Sent: Friday, April 23, 2004 7:42 AM
>>> >> To: axis-c-dev@ws.apache.org
>>> >> Subject: I think Axis c++ is poor cause no one has idea about this
>>> >> problem
>>> >>
>>> >> >>>From: "cheng liang" <chengliang2004@hotmail.com>
>>> >> >>>Reply-To: "Apache AXIS C Developers List"
>>> >> >>><axis-c-dev@ws.apache.org>
>>> >> >>>To: axis-c-dev@ws.apache.org
>>> >> >>>Subject: problem when realize echoStringArray(...) method
in
>>> >> >>InteropBase.wsdl
>>> >> >>>Date: Thu, 22 Apr 2004 01:54:10 +0000
>>> >> >>>
>>> >> >>>Is there someone have interests in this problem?
>>> >> >>>I have been puzzled for quite a time, I will be
>>> >> >>>appreciated if someone can help me.
>>> >> >>>
>>> >> >>>
>>> >> >>>>From: "cheng liang" <chengliang2004@hotmail.com>
>>> >> >>>>Reply-To: "Apache AXIS C Developers List"
>>> >> >>>><axis-c-dev@ws.apache.org>
>>> >> >>>>To: axis-c-dev@ws.apache.org
>>> >> >>>>Subject: problem when realize echoStringArray(...) method
in
>>> >> >>>InteropBase.wsdl
>>> >> >>>>Date: Wed, 21 Apr 2004 02:08:08 +0000
>>> >> >>>>
>>> >> >>>>hi,all,
>>> >> >>>>
>>> >> >>>>I am a newer to Axis in C++.
>>> >> >>>>
>>> >> >>>>I want to realize the InteropBase webservice.
>>> >> >>>>
>>> >> >>>>I generate the server and client code automatically
using
>>> wsdl2Ws
>>> >> >>>>tool according to
>>> >> >>>>the documents on website.
>>> >> >>>>
>>> >> >>>>In client main() method I write:
>>> >> >>>>void main()
>>> >> >>>>{
>>> >> >>>> InteropTestPortType myBase;
>>> >> >>>> ArrayOfstring arrstrValue0;
>>> >> >>>> arrstrValue0.m_Array = new string;
>>> >> >>>> *arrstrValue0.m_Array = "Hello";
>>> >> >>>> arrstrValue0.m_Size = 1;
>>> >> >>>> ArrayOfstring arrstrValue1 >> >>
>>> >>>>myBase.echoStringArray(arrstrValue0);
>>> >> >>>>}
>>> >> >>>>
>>> >> >>>>In server the code is:
>>> >> >>>>ArrayOfstring InteropTestPortType::echoStringArray(ArrayOfstring
>>> >> >>>>Value0)
>>> >> >>>>{
>>> >> >>>> return Value0;
>>> >> >>>>}
>>> >> >>>>
>>> >> >>>>When I run client program, it seems just data has been
sent out
>>> >> >>>>to the server, but server
>>> >> >>>>has no reply, and the client is always waiting.
>>> >> >>>>
>>> >> >>>>My axis has been deployed correctly on apache 1.3.28.
And when I
>>> >> >>>>realize echoInterger(...) method there is no problem.
>>> >> >>>>
>>> >> >>>>I found many times but can not solve this problem.
>>> >> >>>>
>>> >> >>>>Could anyone help me?
>>> >> >>>>
>>> >> >>>>best,
>>> >> >>>>Cheng Liang
>>> >> >>>>
>>> >>
>>> >> _________________________________________________________________
>>> >> ÏíÓÃÊÀ½çÉÏ×î´óµÄµç×ÓÓʼþϵͳ¡ª MSN Hotmail¡£
http://www.hotmail.com
>>> >>
>>> >>
>>> >>
>>> >>
>>> >
>>> > _________________________________________________________________
>>> > Ãâ·ÑÏÂÔØ MSN Explorer: http://explorer.msn.com/lccn/
>>> >
>>>
>>>
>>>
>>
>> _________________________________________________________________
>> ÏíÓÃÊÀ½çÉÏ×î´óµÄµç×ÓÓʼþϵͳ¡ª MSN Hotmail¡£  http://www.hotmail.com
>>
>>
>
>


Mime
View raw message