axis-c-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "cheng liang" <chengliang2...@hotmail.com>
Subject problem when realize echoStringArray(...) method in InteropBase.wsdl
Date Thu, 22 Apr 2004 01:54:10 GMT
Is there someone have interests in this problem?
I have been puzzled for quite a time, I will be
appreciated if someone can help me.


>From: "cheng liang" <chengliang2004@hotmail.com>
>Reply-To: "Apache AXIS C Developers List" <axis-c-dev@ws.apache.org>
>To: axis-c-dev@ws.apache.org
>Subject: problem when realize echoStringArray(...) method in 
InteropBase.wsdl 
>Date: Wed, 21 Apr 2004 02:08:08 +0000
>
>hi,all,
>
>I am a newer to Axis in C++.
>
>I want to realize the InteropBase webservice.
>
>I generate the server and client code automatically using wsdl2Ws 
>tool according to
>the documents on website.
>
>In client main() method I write:
>void main()
>{
>	InteropTestPortType myBase;
>	ArrayOfstring arrstrValue0;
>	arrstrValue0.m_Array = new string;
>	*arrstrValue0.m_Array = "Hello";
>	arrstrValue0.m_Size = 1;
>	ArrayOfstring arrstrValue1 = myBase.echoStringArray(arrstrValue0);
>}
>
>In server the code is:
>ArrayOfstring InteropTestPortType::echoStringArray(ArrayOfstring 
>Value0)
>{
>	return Value0;
>}
>
>When I run client program, it seems just data has been sent out to 
>the server, but server
>has no reply, and the client is always waiting.
>
>My axis has been deployed correctly on apache 1.3.28. And when I 
>realize echoInterger(...) method there is no problem.
>
>I found many times but can not solve this problem.
>
>Could anyone help me?
>
>best,
>Cheng Liang
>
>_________________________________________________________________
>与联机的朋友进行交流,请使用 MSN Messenger:  
>http://messenger.msn.com/cn
>

_________________________________________________________________
享用世界上最大的电子邮件系统― MSN Hotmail。  http://www.hotmail.com  


Mime
View raw message