axis-c-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Leo Stutzmann" <lstutzm...@platform.com>
Subject Axis C++ Question.
Date Fri, 13 Feb 2004 14:55:16 GMT
Hi,

I am new to using Axis C++, and may need help getting oriented in the right direction.

I downloaded the Windows version of Axis C++ dated Dec 24, 2003. I installed it according
to the installation instructions.

I started the SimpleAxisServer using port 80 to try the examples. The server started and responds
with:
Document parsing successful
server.wsdd loading successful

I start the base executable to run the tests and it says:
invoking echoString...
and then crashes with an acces violation in SimpleAxisServer.exe:
AppName: simpleaxisserver.exe	 AppVer: 0.0.0.0	 ModName: simpleaxisserver.exe
ModVer: 0.0.0.0	 Offset: 0000f2c7

I debugged the code and found the access violation at:

    soap->so.http.op_headers[count].headername = pchkey; (in set_header() of Packet.cpp)

The count is set at the top of this function with soap->so.http.op_headercount, and op_headercount
is a bad value (large negative number).

I added an initializer statement to executework in simpleaxisserver:
    str->so.http.ip_headercount = 0;
    str->so.http.op_headercount = 0;

To set the value to 0 as in the input header.

Then when I run base, base finishes all the tests, but every test failed.

I probably have done something wrong here, any help would be appreciated to get an installation
working, at least being able to run through the tests in base and groupB successfully.

thanks
Leo

Mime
View raw message