axis-c-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From <dami...@opensource.lk>
Subject Re: Building under Linux
Date Thu, 29 Jan 2004 09:26:54 GMT
Hi elrod,

Now apache2 support is there. You need to change
$AXISCPP_HOME/configure.ac to select apache2 option. After that you need
to rebuild
sh autogen.sh
sh runconfig
make install

You need to copy the apache2 include files in $AXISCPP_HOME/include/apache2/

thanks,
damitha.

> Hi elrod,
> Yes, you need to install it in order to get os.h get created propoerly.
> I ealier built it on apache1.3.27. But I again tested it with
> apache1.3.29 and it works fine.
> I think it wouldn't be a problem running a test apache1.3 version in a
> different port. Anyway I hope to write a module to support apache2 soon.
>
> damitha
>
>> I downloaded apache_1.3.29.tar.gz and compiled it. There is not an
>> apache_1.3.29/include directory but there is an
>> apache_1.3.29/src/include dir. I did copy that. If you notice - it
>> does find the apache includes - the problem seems to be with os.h
>> included from
>>
>> ws-axis/c/include/apache1_3/ap_config.h
>>
>> I just searched and there is an os.h in apache_1.3.29/src/os/unix/os.h
>> but not one in apache_1.3.29/src/include... when I copy that file over
>> it errors on os-inline.c. I did not do a make install - do I have to?
>> I do not want to install apache 1.3 on this box... :( I think it has
>> apache 2 on it right now...
>>
>> elrod
>>
>> damitha@opensource.lk wrote:
>>
>>>Hi elrod,
>>>Ok, Linux build work fine now. Earlier it was my silly mistake.I'll
>>> further test it and commit the code.
>>>
>>>Anyway your build error seems to come from your not copying apache
>>> include file into $AXISCPP_HOME/include/apache1_3.
>>>
>>>thanks
>>>damitha
>>>
>>>
>>>
>>>>I figured I can do my own test on Linux since I have access to a
>>>> Linux
>>>> box. It is a RedHat 9 machine. I followed the build instructions and
>>>> when I make it I get the following error output:
>>>>
>>>><snip a lot of output>
>>>>mkdir .libs
>>>>gcc -DHAVE_CONFIG_H -I. -I../../../../src/server/apache -I../../..
>>>> -I/home/elrod/ws-axis/c/include -Wshadow -Wall -pedantic -ansi -Wall
>>>> -Wshadow -c ../../../../src/server/apache/mod_axis.c -MT mod_axis.lo
>>>> -MD
>>>> -MP -MF .deps/mod_axis.TPlo  -fPIC -DPIC -o .libs/mod_axis.lo
>>>>In file included from
>>>>/home/elrod/ws-axis/c/include/apache1_3/httpd.h:72,
>>>>                 from ../../../../src/server/apache/mod_axis.c:1:
>>>>/home/elrod/ws-axis/c/include/apache1_3/ap_config.h:114:16: os.h: No
>>>> such file or directory
>>>>In file included from /usr/include/sys/sem.h:28,
>>>>                 from
>>>>/home/elrod/ws-axis/c/include/apache1_3/ap_config.h:499,
>>>>                 from
>>>>/home/elrod/ws-axis/c/include/apache1_3/httpd.h:72,
>>>>from ../../../../src/server/apache/mod_axis.c:1:
>>>>/usr/include/sys/ipc.h:25:3: warning: #warning "Files using this
>>>> header must be compiled with _SVID_SOURCE or _XOPEN_SOURCE"
>>>>../../../../src/server/apache/mod_axis.c: In function `axis_handler':
>>>> ../../../../src/server/apache/mod_axis.c:197: warning: assignment
>>>> from incompatible pointer type
>>>>../../../../src/server/apache/mod_axis.c:198: warning: assignment
>>>> from
>>>> incompatible pointer type
>>>>../../../../src/server/apache/mod_axis.c:199: warning: assignment
>>>> from
>>>> incompatible pointer type
>>>>../../../../src/server/apache/mod_axis.c:200: warning: assignment
>>>> from
>>>> incompatible pointer type
>>>>make[4]: *** [mod_axis.lo] Error 1
>>>>make[4]: Leaving directory
>>>>`/home/elrod/ws-axis/c/build/src/server/apache' make[3]: ***
>>>>[all-recursive] Error 1
>>>>make[3]: Leaving directory `/home/elrod/ws-axis/c/build/src/server'
>>>> make[2]: *** [all-recursive] Error 1
>>>>make[2]: Leaving directory `/home/elrod/ws-axis/c/build/src'
>>>>make[1]: *** [all-recursive] Error 1
>>>>make[1]: Leaving directory `/home/elrod/ws-axis/c/build'
>>>>make: *** [all] Error 2
>>>>[elrod@gold build]$
>>>>
>>>>
>>>>damitha@opensource.lk wrote:
>>>>
>>>>
>>>>
>>>>>Hi elrod,
>>>>>
>>>>>
>>>>>
>>>>>
>>>>>
>>>>>>This is under linux right? Are the errors when compiling Axis? Can
>>>>>> you tell me which files?
>>>>>>
>>>>>>
>>>>>>
>>>>>>
>>>>>yes it is uder linux. The problem comes when I build
>>>>>SecurityChannel.cpp. Is it possible for you to apply your patch to
>>>>> the latest from cvs head and test it and send me the diff
>>>>>
>>>>>damitha
>>>>>
>>>>>
>>>>>
>>>
>>>
>>>
>>>
>>>
>>
>> --
>> Mark Elrod
>> Vindicia, Inc.
>> 2755 Campus Drive, Suite 240
>> San Mateo, California 94403
>>
>> Email: elrod@vindicia.com
>> Cell:  650-483-5763
>> Work:  650-522-4484
>> Main:  650-522-4480
>> Fax:   650-345-1165
>> Web:   http://www.vindicia.com




Mime
View raw message