axis-axis1-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andreas Veithen <andreas.veit...@gmail.com>
Subject Re: Axis 1.1(Java): Problem with missing namespace prefix in SOAP Body
Date Sun, 19 Feb 2012 11:47:26 GMT
On Sat, Feb 18, 2012 at 13:04, santhosh kotte <santhoshkotte@yahoo.com> wrote:
>
> Hello
> I am using Axis 1.1 to call a web service.

You just said that you are using Axis 1.4. Can you clarify this please?

> While converting a  org.w3c.dom.Element into a org.apache.axis.message.SOAPBodyElement
the namespace prefix present in the Element is being removed.
> Eg:
> Following is the Element
> <ns:Extend xmlns:ns="http://xyz" ></ns:Extend>
> When it is converted into  SOAPBodyElement it becomes
> <Extend></Extend>
>
> I am using the following constructor to create SOAPBodyElement from Element type.
> SOAPBodyElement sle=new SOAPBodyElement(bodyElement);
> where bodyElement is the Element type.
>
> The second issue is that the multiple namespace prefixes are generated for the same namespace
URI when the Element type is converted to SOAPBodyElement type.
> Eg:
> xmlns:x="http://xyz"
> xmlns:y="http://xyz"
> xmlns:z="http://xyz"
>
> Can anyone please help me in resolving this issue?
>
> Thanks in advance
> santhosh

---------------------------------------------------------------------
To unsubscribe, e-mail: axis1-java-user-unsubscribe@axis.apache.org
For additional commands, e-mail: axis1-java-user-help@axis.apache.org


Mime
View raw message