avro-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Doug Cutting <cutt...@apache.org>
Subject Re: Avro and Jackson dependency
Date Fri, 08 Aug 2014 18:15:52 GMT
Avro currently requires Jackson 1.x.  Jackson 2.x has an incompatible
API in a different package.  The two versions of Jackson do not
conflict so both may be used within a single application.

Whether & when to eventually upgrade Avro to use Jackson 2.x is discussed in:

  https://issues.apache.org/jira/browse/AVRO-1126

Doug

On Thu, Aug 7, 2014 at 9:41 AM, Casadio Phaedra
<Phaedra.Casadio@datamanagementpa.it> wrote:
> After compiling my schema to java, i’ve this error in class files:
>
>
>
> The type org.codehaus.jackson.JsonParser cannot be resolved. It is
> indirectly referenced from required .class files
>
>
>
> In my project i’ve last Jackson version 2.4.1, seems that avro is using a
> real old one?
>
>
>
> Also in generated bean i’ve found some deprecations, it’s normal?
>
>
>
> Thanks Phaedra.

Mime
View raw message