avro-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mike Stanley <m...@mikestanley.org>
Subject Avro 1.7.6 Rubygem Issue
Date Mon, 10 Feb 2014 20:09:35 GMT
Hi all.

Long time Avro user, but new to the list...

I just wanted to call out that the new version of the Rubygem 1.7.6 is broken.

Trying to install it now will yield the error:

ERROR:  While executing gem ... (Gem::DependencyError)
    Unable to resolve dependencies: avro requires multi-json (>= 0)

To fix this, in file:
http://svn.apache.org/repos/asf/avro/trunk/lang/ruby/Rakefile

change 'multi-json' on line:

   p.runtime_dependencies = %w[multi-json]

to  'multi_json'


Cheers,
... Mike

Mime
View raw message