avro-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jacob Metcalf <jacob_metc...@hotmail.com>
Subject Re: avro 1.7.0 with CDH4
Date Thu, 05 Jul 2012 12:12:49 GMT
Avro 17 is compiled against Hadoop 1 i.e. CDH3.

I have it running aginst CDH4 but I had to patch and recompile Avro, then replace the Avro
153 in the Hadoop lib directory with 17. I have attached my patch against JIRA AVRO-1103 for
consideration.

-----Original Message-----

From: Alan Miller
Sent: 5 Jul 2012 11:03:06 GMT
To: avro-user@hadoop.apache.org
Subject: Re: avro 1.7.0 with CDH4


I noticed that CDH4 has avro-1.5.4.jar in hadoop/lib so I modified my job so
that:

 1.  avro-1.7.0.jar and avro-tools-1.7.0.jar is contained within my jar file
in ./lib/
    (note: I submit my job via hadoop jar myjar.jar myDriver <myopts ....>)
 2.  I have also set: mapreduce.task.classpath.first=true (in
mapred-site.xml)
      to ensure the 1.7.0 jars from the lib dir in my.jar are used first
(before avro-1.5.4).

But I still get the same error.

Any ideas?

Alan

--
View this message in context: http://apache-avro.679487.n3.nabble.com/avro-1-7-0-with-CDH4-tp4025149p4025150.html
Sent from the Avro - Users mailing list archive at Nabble.com.

Mime
View raw message