avro-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Something Something <mailinglist...@gmail.com>
Subject Re: Java MapReduce Avro Jackson Error
Date Tue, 20 Mar 2012 01:43:42 GMT
I recall running into a similar issue a while back.  In our case, the
problem was that the classes from the jar file in /hadoop/lib were
overriding those in the shaded Jar from Maven - or something like that.  I
will look into my notes & see if I can find more info.

On Mon, Mar 19, 2012 at 6:34 PM, Tatu Saloranta <tsaloranta@gmail.com>wrote:

> On Mon, Mar 19, 2012 at 6:23 PM, Deepak Nettem <deepaknettem@gmail.com>
> wrote:
> > Hi Tatu / Scott,
> >
> > Thanks for your replies. I replaced the earlier dependencies with these:
> ...
> > I still get the same error. Is there anything specific I need to do other
> > than changing dependencies in pom.xml to make this error go away?
>
> Sounds like some other library has been compiled against old Jackson
> version then.
> Perhaps one of hadoop core jars?
>
> Whatever library it is needs to be compiled against Jackson 1.1 or newer.
>
> -+ Tatu +-
>

Mime
View raw message