avro-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From snikhil0 <snik...@telenav.com>
Subject Re: Avro and Hive contd
Date Fri, 16 Mar 2012 22:27:37 GMT
Hello Jakob,

I tried both options:

1. copied the jars (jackson*, avro*, haivvero*) to $HIVE_HOME/lib
2. pointed the HIVE_AUX_JARS_PATH to a folder that contained all the above
jars.

Started hive.

list jars; does not show me the above jars?
Only if I add the jars manually using add jar do I get the desired jars as
an output on list jars;

However, I tried all cases and I still get the same error...Schema_init..
java.lang.NoClassDefFoundError

What am I doing wrong?

System:
Hive 0-7.1-bin also tried 0.8.1-bin
avro 1.4.2 (also tried 1.5.3 and 1.6.2)
jackson (corresponding versions)
hadoop-0.20.205 (also tried running local without hadoop)

Thanks,
Nikhil

--
View this message in context: http://apache-avro.679487.n3.nabble.com/Avro-and-Hive-contd-tp3773468p3833357.html
Sent from the Avro - Users mailing list archive at Nabble.com.

Mime
View raw message