avro-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "W.P. McNeill" <bill...@gmail.com>
Subject Re: Data incompatibility between Avro 1.4.1 and 1.5.4
Date Tue, 04 Oct 2011 17:10:54 GMT
I can read the data with the same schema it was written with. Given your
answer and other aspects of the problem I've uncovered I suspect now that
the problem is confused Hadoop classpaths pulling in an older version of
Avro unpredictably.

If this hypothesis proves to be wrong and I go back to suspecting serialized
incompatibility between Avro versions I'll try to narrow down a repro case
for you.

On Mon, Oct 3, 2011 at 7:12 PM, Scott Carey <scottcarey@apache.org> wrote:

> AVRO-793 was not a bug in the encoded data or its format.  It was a bug in
> how schema resolution worked for certain projection corner cases during
> deserialization.
>
> Is your data readable with the same schema that wrote it?  (for example,
> if it is an avro data file, you can use avro-tools.jar to print it out
> with its own schema).
> If the error only occurs when you try to use a different schema to read
> than it was written with, it is most likely a bug with the schema
> resolution process.  If so, file a bug.  We will need to reproduce it, so
> the more information you can give us about the schemas the better.  Best
> would be a reproducible test case but that may not be trivial.  At minimum
> the stack trace you get with 1.5.4 could be enlightening.
>
> Thanks!
>
> -Scott
>
>
> On 10/3/11 3:32 PM, "W.P. McNeill" <billmcn@gmail.com> wrote:
>
>
> >I have a bunch of data that I serialized using the Avro 1.4.1 library. I
> >wanted use projection schemas with this data but I can't because of bug
> >793 (https://issues.apache.org/jira/browse/AVRO-793). So I changed my
> >code to use Avro 1.5.4. When I try to deserialize the Avro 1.4.1 data
> >with the new code built with Avro 1.5.4, I get the same runtime
> >deserialization errors described in JIRA 793.
> >Is this expected? Is there any way around it beyond reserializing all my
> >data using Avro 1.5.4?
> >
> >(I think I'm asking whether JIRA 793 is just a problem with
> >deserialization or a problem with the binary serialization format.)
>
>
>

Mime
View raw message