avro-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "W.P. McNeill" <bill...@gmail.com>
Subject Data incompatibility between Avro 1.4.1 and 1.5.4
Date Mon, 03 Oct 2011 22:32:57 GMT
I have a bunch of data that I serialized using the Avro 1.4.1 library. I
wanted use projection schemas with this data but I can't because of bug 793
(https://issues.apache.org/jira/browse/AVRO-793). So I changed my code to
use Avro 1.5.4. When I try to deserialize the Avro 1.4.1 data with the new
code built with Avro 1.5.4, I get the same runtime deserialization errors
described in JIRA 793.

Is this expected? Is there any way around it beyond reserializing all my
data using Avro 1.5.4?

(I think I'm asking whether JIRA 793 is just a problem with deserialization
or a problem with the binary serialization format.)

Mime
View raw message